Hello Guest it is December 15, 2019, 09:26:32 AM

Author Topic: Mach 4 and ESS latest update issues  (Read 1427 times)

0 Members and 1 Guest are viewing this topic.

Mach 4 and ESS latest update issues
« on: August 10, 2016, 08:47:55 PM »

Hey all, first post here. My colleague and i have been building a custom cnc machine with a laser attach.

We have had some issues since updating to the latest versions of Mach and ESS plugin. Vers.1.01.186 for ESS plugin and 4.2.0.2914 for Mach 4

We had it working decently previous, but now when we go to run gcode, it either runs perfectly and repeateably without the laser, or works intermittently (first time works, then fails, or doesn't work at all) and fails randomly with the laser.

We had tried to nail down specific variables, changing g code, or machine settings, we even tried the order we loaded the profile/homed/loaded code etc, nothing works consistently. But we've hit our heads on the wall long enough, time to ask for help.

Ideally we'd like to be running using the g62/63 codes to control the laser on z movement.

But we would be happy with consistent runs on a job even if it required more manual work on our part.

If there's something specific you'd like to see or have us try please suggest!

Offline Tweakie.CNC

*
  • *
  •  8,024 8,024
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 4 and ESS latest update issues
« Reply #1 on: August 11, 2016, 04:14:34 AM »
Quote
Ideally we'd like to be running using the g62/63 codes to control the laser on z movement.

Just a note - the M62/M63 codes are not yet implemented in the Mach4 ESS plugin. It will happen but it may be a while.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Mach 4 and ESS latest update issues
« Reply #2 on: August 11, 2016, 11:25:31 PM »
Hi,

How do you control the intensity of your laser? Also, what do you define as 'works intermittently'? Please give us more details about your particular setup.

Offline Pedio

*
  •  200 200
    • View Profile
Re: Mach 4 and ESS latest update issues
« Reply #3 on: August 12, 2016, 02:29:02 PM »
Hi,

How do you control the intensity of your laser? Also, what do you define as 'works intermittently'? Please give us more details about your particular setup.
I control the intensity of the laser by treating it as a spindle. I changed the post processor on my CAM to activate the spindle on a downward move and disable the spindle on an upward move. The spindle speed is 0-100 and I have assigned the different speeds to the tools I choose for the laser.

Of course I have disabled the Z axis movement in the post processor. I am using Vcarve Pro. If you want a copy of my post processor just PM me.

As for the files locking up. I have had that problem when on M5 commands for quite some time. Version 2872 seemed to take care of it but it is back with version 2914. Usually I can disable M4, then enable it, and hit start and the program will continue.

My laser Gcode files are pretty big since I color in areas with the laser. I think that is why we notice some of these problems more.
Re: Mach 4 and ESS latest update issues
« Reply #4 on: August 12, 2016, 08:27:28 PM »
Hi sorry for the late reply!

We control the intensity of the laser through the g code and PWM chip we set up with the ESS.

ie; spindle speed in g code of 10,000 gives us a certain output on the laser. We measure it via an analog meter we put inline to the laser power source that's measured in mA. And we know that our high peak on this particular tube shouldn't go above 20-25mA (30mA is our upper MAX we should not hit before it hurts the life of the laser)

We went through a couple hours of troubleshooting, and we believe that we narrowed the cause down, is in the New ESS plugin there are more options relating to PWM and the spindle controls.
We initially set these up to the mode as PWM, and the frequency for 25kHz, as the C02 laser we bought suggest that it should be at 20kHz or higher.

After some testing, and experimenting with the settings  at different "spindle speeds" and max spindle speeds, and frequencies. We had a pretty consistent result to what is failing on and when, but we don't know how or why it is failing. Feels like something is maybe getting feedback somehow and causing mach to not continue with the program.

The biggest culprit seemed to have to do with the PWM frequency, and the Spindle speed % of max Spindle speed set in the plugin. It would not work with frequencies set much lower than 20kHz, like 1kHz for example, and too far about 20 didn't have much success either.


The testing at the 25kHz setting and a max spindle speed of 125,000 we found that at about roughly 42,500 for spindle speed set in g-code is where we found issues with consistency, running maybe 1/8 fulls paths. This gave us outputs of around 10mA at 100% speed, and 18mA at 150% At this point it would lock up on the program side.

We stopped testing and stuck with 20kHz for now, and a max spindle speed of 60,000.
Our max spindle speed is roughly 25,000 give us an output of 7.5mA at 50%, 13mA at 100%, 21.5mA at 150% of the spindle speed (this was where it "failed") This was the biggest range we found that could be successful consistently, without further testing.


We experimented with different spindle speeds, and the scale seemed pretty much the same no matter what "max" we set, a little after 1/3rd of max spindle speed it would fail program side.
I say fail, but there isn't any alarms tripped, and no error codes presented, just stops running the lines of code.

We are thinking it's either stalling out as some signal that the boards don't like, and it just stops it going any further, or some hidden thing in the mach/ess software that we can't see or aren't aware of forbidding certain combinations of settings. As we don't don't have signal coming back from the laser to the PWM chip or ESS.

I will be at the shop again sunday and can provide the files from Mach then(Gcode, ini, etc) or screens of our settings or notes if needed, but just updating this from home right now.