Hello Guest it is October 27, 2021, 07:13:40 AM

Author Topic: Homing  (Read 5351 times)

0 Members and 1 Guest are viewing this topic.

Homing
« on: August 04, 2016, 08:06:32 PM »
Hi all, I need help. My cnc when I hit the go to Z button the machine is moving to zero DRO in all axis in  the work coordinates not the machine coords. Why? The axis are not hitting the home switches at all. Is there something I am missing? In the General config I have the home switches checked but does nothing, does anyone have any sujestions
Re: Homing
« Reply #1 on: August 04, 2016, 10:52:28 PM »
It's doing exactly what it's supposed to do.  Go to Zero works in the WC system.  You need to use a G28 command with at least one axis reference (i.e. Z0) to move to the home zero location (i.e. Machine Coordinates) or you could use explicit MC movements with a G53 command.  Remember, G53 is not a modal command and must be explicitly stated in each block that you want to move in MC movements.  G53 can be used to move any axis or combination thereof to a specific location in the MC system whereas G28 is specific to homing.

Hope this helps.

Stephen "Highspeed" Kruse

EDIT:  The axis word(s) in G28 are optional.  Also a G28.1 will reference all or specified movements to the home switches.
« Last Edit: August 04, 2016, 10:56:20 PM by Highspeed1964 »
Re: Homing
« Reply #2 on: August 05, 2016, 05:30:19 AM »
The only problem is that I cant get the machine coordinates to zero for my work table. Just remember that I am new to this so can you please put it in simple English. I had it working right before but now it's not.
Re: Homing
« Reply #3 on: August 05, 2016, 12:31:31 PM »
Oh, ok.  So are you using the "REF ALL HOME" button to zero your table machine coordinates?  Go to Zero is not the one to do this.  As mentioned earlier, Go to Zero will move the tool to X0Y0Z0 (and A0 if you have a 4th axis) in Work Coordinates.  You must use the REF ALL HOME button to set the MC zero to your table.

Stephen "Highspeed" Kruse
Re: Homing
« Reply #4 on: August 07, 2016, 05:30:46 PM »
Stup I'd me I was pushing the wrong button to ref all home. But 1 issue I am having is I have z reffing to got to the home switch but when it does it just hits the limit switch and stops it doesn't bounce off the switch.  I played with a few settings and got it working but when I try it again it just throw s the limit switch and stops. What is wrong?  The x and y work fine but the z keeps messing up. Am I setting something wrong?
Re: Homing
« Reply #5 on: August 08, 2016, 05:26:18 PM »
Sorry to take so long to respond to your last question, but I've been pouring over the settings to see if I could find a quick answer for you.  Not finding anything that stands out.  But a couple of questions for you:

1.  Is your Z Axis set to home in a positive direction (i.e. Zero at the top of the movement)?
2.  Does your Z Axis move UP for positive values and DOWN for negative?

It's possible the logic in your configurations is reversed at one setting or another.  So when it homes, it could be possible that it's moving to the limit and then trying to move further in the same direction to "back off" the home/limit switch.  You'd probably know this, however, as you'd be hearing it try to continue as it crashes into the mechanical limit of the machine.  But it's something to check.  Make sure the Z Axis moves up for positive and down for negative and then check that "Home Negative" is UNCHECKED so that it knows it is the positive limit it is looking for.  Then when it tries to home the axis, it should seek the upper limit switch and then back off until the switch is no longer active.

This, of course, assumes you are using shared home/limit switches.  The same should be true if you have a dedicated home switch as well but I do not know for sure.

Stephen "Highspeed" Kruse
Re: Homing
« Reply #6 on: August 08, 2016, 05:52:50 PM »
The  machine is set to move up in the positive direction and is not checked home in the negative.  The machine was operating fine 2 months ago as I have been busy with other work. I had to move the machine to a different spot when I fired it up its all messed up on the z axis again. I had the same problem a year ago and don't remember what I had to do. When it was working correctly I saved all the settings but now it's all messed up.
Re: Homing
« Reply #7 on: August 08, 2016, 08:20:46 PM »
I had the cnc operating the way it should so I saved the setting closed the program and when I reopen mach3 the dro s are not the same as before and when the z moves up toward the switch it trips the limit and stops. Does not over travel.
Re: Homing
« Reply #8 on: August 08, 2016, 08:52:07 PM »
The only problem is that it will not bounce off the z home switch

Offline ger21

*
  • *
  •  6,293 6,293
    • View Profile
    • The CNC Woodworker
Re: Homing
« Reply #9 on: August 08, 2016, 09:51:35 PM »
Try adding some Debounce.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html