Hello Guest it is May 24, 2019, 11:45:02 PM

Author Topic: 6040 CNC with Gecko 540 Z axis problem  (Read 912 times)

0 Members and 1 Guest are viewing this topic.

6040 CNC with Gecko 540 Z axis problem
« on: August 02, 2016, 11:01:24 PM »
Hello, I have a 6040 with a Gecko 540 and running Mach 3. I zero out the z axis manually and it gradually dives deeper than expected through out the run of a part. I tried slowing down the travel and acceleration on the z axis, but this only slows down the dive. Any help would be greatly appreciated.
Re: 6040 CNC with Gecko 540 Z axis problem
« Reply #1 on: August 02, 2016, 11:57:24 PM »
It sounds like it could be missed steps, but another likely suspect is that acceleration.  If I understand it correctly, slowing down the acceleration would actually increase errors.  When I was first setting up my 6040, I had it too slow and ended up with rounded corners on flat pieces until I stepped UP the acceleration.  So the motor was still slowing down when the next commanded move began.  Now bear in mind that this is on the X and Y axis motors.

When it comes to the Z Axis, you're fighting gravity on the upward movement and working with it on the downward movement.  So it's possible there may not be enough torque being developed to hold the spindle and mount in sync with the motor signals and this would cause skips/missed steps.  You may need to check any configuration switch settings to make sure the driver is providing the proper amount of current to the motors.

There are many things to check and not being familiar with the Gecko drivers I'm speaking in a more generalized manner on this, so I can't be of more help than this.  But I hope it at least helps get you pointed in the right direction.

Stephen "Highspeed" Kruse