Hello Guest it is October 15, 2019, 08:04:20 AM

Author Topic: Motors are not operating correctly  (Read 4953 times)

0 Members and 1 Guest are viewing this topic.

Motors are not operating correctly
« on: July 18, 2016, 04:31:08 PM »
I embarked on a cleaning/lubrication routine with my G0704 mill over last weekend. However, when I attempted to jog through each axis there were problems with not moving at all and moving in the wrong direction. For example, it should have moved in X- direction, but both arrow keys would result going in the X+. Then the Z would move in the positive direction, but not at all when attmpting to move in the negative. This would happen a few times, work correctly for awhile, and then start acting up again. All the connections seem secure and there has been no changes to hardware or Mach 3 settings. There were no error messages from Mach 3 or UC100. My machine has the following hardware:

UC100 USB motion controller
 (2) KL-5056D drivers
 (1) KL-8070D driver
 (2) KL23H2100-50-4B, NEMA23 570oz/in 5A 3/8” Dual Shaft Stepper Motor
 (1) KL34H295-43-8A, NEMA34 Stepper Motor – 906oz in 6.1A Single Shaft
 48V/12.5A Power Supply, 115V/230V
 KL-DB25 BOB

 Mach 3

 I am not sure if this is a hardware and/or software issue. Would should I start to rule out to trouble shoot this? Thanks.
Re: Motors are not operating correctly
« Reply #1 on: July 18, 2016, 06:19:17 PM »
Physically check your direction signal wires between controller & drivers, I'd be tempted to get a meter on the job,

 - Nick
Re: Motors are not operating correctly
« Reply #2 on: July 18, 2016, 10:00:13 PM »
I suspect you may have gotten cleaner/lubricant into the motors or motor wiring.  Or maybe even just jostled the wires loose in the connectors.  Just my $.02

Stephen "Highspeed" Kruse
Re: Motors are not operating correctly
« Reply #3 on: July 20, 2016, 09:26:41 PM »
Drivers, BOB, and power supply are in a control box and wiring for motors are contained within motor covers, so isolated from lubricant.  The cleaning didn't involve any chemicals, and the lubricant has been used may times before and was no where near wires/components.  I went the over connections and all seem secure.  This is frustrating to say the least considering everything was working fine.  I am by no means electronic proficient, so excuse me if my questions seem stupid.  Specifically how do I check with a meter direction signal wires between controller and drivers?  What numbers should I be looking for?  Anything else to check?  Thanks.   
Re: Motors are not operating correctly
« Reply #4 on: July 21, 2016, 02:18:35 AM »
Yep, you're correct in assuming that you need to check the direction lines (at least in the case of the X axis), but not sure how to really explain the use of a meter briefly enough to state in a forum post.  The Z axis acting the way it does (intermittently) still indicates to me something is loose somewhere or a wire got broken inside the insulation.  It definitely seems weird that this happened from routine maintenance (cleaning/lubrication) of the machine.

The other possibility is that something got shorted out in the drivers as a result of liquid getting into the contacts or wiring pins touching while power was applied.  I'm sure, though, that you didn't do this maintenance without turning off the machine first, right?

Could you try swapping the motors to different axis drivers and see if the symptom follows the motor or stays with the driver output?  BE CAREFUL doing this as you'll easily get confused as to which axis should be moving for a given control and you may crash your spindle, tool or other components against other things and this is not good.  Just short, slow movements to verify the driver/motor is working correctly.  If the symptom stays with the motor, your drivers are good and you need to inspect the wiring more closely including weird kinks in the insulated sections where there may be broken wiring inside.

Let me know what you find and we'll keep looking if needs be.

Stephen "Highspeed" Kruse
Re: Motors are not operating correctly
« Reply #5 on: July 21, 2016, 06:56:35 PM »
Stephen, The mill has been untouched since yesterday evening.  Before I attempted anything, I jogged each axis to see what would happen.  Everything worked in the positive and negative directions for each axis with the keyboard and via Mach for approximately fifteen times in each direction.  Then I jogged again and the following were the results: Z+ worked, Z- no movement, Y+ and Y- moved toward Y- direction regardless of what key associated with Y axis was pressed, X- and X + moved to X- regardless of what key associated with X axis was pressed.  Then I waited about ten minutes and it worked again in all directions for approximately ten times each.  No further attempts to try anything.  What do you make of the aforementioned?  Any other suggestions to check?  Thanks.
Re: Motors are not operating correctly
« Reply #6 on: July 21, 2016, 07:30:24 PM »
Hmmmm, definitely something flakey.  Could be a heat issue, either with the motors themselves or with the stepper drivers.  You may need to see about putting some cooling fans on the drivers since we're getting into the hotter months of the year.  They may have worked in the past, even during the hot months, but as they get older the heat could become more of an issue.  And since they worked for a few cycles, then started going wonkey but worked again after letting them rest a while heat is definitely a likely culprit.

You said your drivers are enclosed, so is there sufficient ventilation on the enclosure?  Is there a fan in that that may have stopped working?

Check to make sure your drivers are staying cool enough and then check your motors, too.

Let me know.

Highspeed
Re: Motors are not operating correctly
« Reply #7 on: July 22, 2016, 09:10:38 AM »
The control box was purchased/made specifically for enclosing CNC components and has a CPU fan.  I have been utilizing a wireless keyboard and mouse for approximately six months without any apparent problems.   Also, have a wireless internet connection on the computer for updates of CNC based software.  Can any of these potentially cause interference with drivers, etc. resulting in something like intermittent directional issues?  Thanks. 

Offline Davek0974

*
  •  2,578 2,578
    • View Profile
    • DD Metal Products Ltd
Re: Motors are not operating correctly
« Reply #8 on: July 22, 2016, 09:50:31 AM »
It is ALWAYS a good idea never to have network or wifi on the control pc, it can work but is a known source of all thats bad.

The control PC should only run the control program - Mach 3/4 etc and nothing else.

It would be worth trying a clean boot with networking turned off etc just to check

I have never tried a wifi keyboard but i cant see it being an issue - the interference would have to cause the exact signal as the Z down function needs and i think that would be pretty rare, more like it would just lose connection if interference was present.

Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: Motors are not operating correctly
« Reply #9 on: July 22, 2016, 11:13:20 AM »
One thing I have noticed is that if the UC100 is off of the port slightly, motors will reverse directions sometimes out of the blue.  Make sure there is a good connection between the UC100 and BOB.  Try and eliminate any cable between the UC100 and BOB if possible.