Hello Guest it is May 23, 2019, 03:33:21 PM

Author Topic: Spindle control problem  (Read 1016 times)

0 Members and 1 Guest are viewing this topic.

Spindle control problem
« on: July 09, 2016, 08:45:35 AM »
Hello,

I am finishing my spindle setup with Gecko G540 and i have badly stucked. So far I was able to setup VFD in the right way for my spindle (1.5Kw 400hz 220V) And now I have and issue i cant solve. I have my wires plugged right i followed mach 3 settings everything seems to communicate well but:

When I hit the Spindle button to switch the spindle on (I have my minimum RPM set to 650) the spindle comes on and I have S 650 in the spindle small window and it cannot be adjusted (see picture). The spindle is running but it cant be switched off with the same button or the speed cant be changed no matter what, the only way how to switch the spindle off is by switching the whole VFD off. Also the RPM is not showing at all there is still 0 even the spindle is spinning. I found simmilar threads for this on the forum, i followed the setting, but now i stucked can please anyone help? I want be able to see RPM of the spindle and also be able to swith it on and off with mach3 so it starts with the job by it self. Thank you very much in advance. Please see my settings attached.
Re: Spindle control problem
« Reply #1 on: July 21, 2016, 03:12:40 AM »
From what I can see in your screen shots, you have the PWM output on pin 14 and a control signal configured for pin 17, correct?  However, you do not have the Spindle Relays enabled in the last screenshot.  Normally, you would have the PWM setting the spindle speed and then the configured output (Output 1 on Port 1 Pin 17 in your case) driving a relay to send the VFD a start/stop control.  This would likely be a relay that connects a "Common" lead to the Start or FWD Run pin on the VFD itself.  Otherwise, the VFD would have to be set to Run manually and then the PWM would control the speed and if Mach 3 is told to set the speed to 0 the spindle would stop running, but still be engaged.

I would suggest unchecking the "Disable Spindle Relays" on the Spindle Setup tab and setting BOTH outputs (M3 and M4) to the output you configured in the "Output Signals" tab - Output 1 in your setup.  Make sure the output you configured controls a relay to close the path between the "Common" and FWD Run pins on the VFD.

I'm not sure why you cannot change the spindle speed, but if you're running a program you should be using the SRO (Spindle RPM Override) to adjust the actual RPM.  (I see you don't have that on your screen set.  You may need to upgrade to the newest release of Mach 3 to get it.)

Hope this helps,

Stephen "Highspeed" Kruse