Hello Guest it is May 20, 2019, 07:08:24 AM

Author Topic: Limit/Home switch X-axis problem...  (Read 3125 times)

0 Members and 1 Guest are viewing this topic.

Offline lemo

*
  •  139 139
    • View Profile
Limit/Home switch X-axis problem...
« on: May 21, 2007, 03:44:06 PM »
Great, I have all limit and home switches mounted on the machine. All works but the X-Axis....

When I let the machine home, it homes to the wrong side of the x axis. If I reverse the axis or home negative, the move to home seems to be alright, but then it simply drives into the end switch and instead of reporting home and auto-zero, it simply reports LIMIT SWITCH HIT and that's the end of that. How can I home to the right end switch and not to the left one?

Right now my tool 0,0,0 is above the right most corner towards the operator. It should be the left most corner so positive x movements go to the right.

Btw... I can inverse the Y-Axis and home and negative home. All good. All works. Just the X-Axis does not do the same. It only homes to one side and indicates a limit switch hit on the other side (negative homing).

Thanks for a hint, it's the only thing preventing me to run the machine. Sighhhh.
Lemo
« Last Edit: May 21, 2007, 08:23:49 PM by lemo »
Cut five times and still to short...
Re: Limit/Home switch X-axis problem...
« Reply #1 on: May 22, 2007, 01:00:37 AM »
Have a look at the diagnostics page when you are about to home. Are there any other switches that are pressed?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline lemo

*
  •  139 139
    • View Profile
Re: Limit/Home switch X-axis problem...
« Reply #2 on: May 22, 2007, 07:57:08 AM »
No, no other switch. I did another test, pretty much the last thing which came to my mind. And that is to disable the limit X- -- or X- ++. THEN the homing works without the dreaded limit switch error.
BUT the limit switch function is dead (switched off), the homing with the switch clearing drive only happens on one side of the home drive. A negative home drive simply does not work right.
Is there a code module I can look at which is performing this task. I'm more than capable to help myself once I know where the faulty code is located.
Cheers
Lemo
Cut five times and still to short...

Offline lemo

*
  •  139 139
    • View Profile
Re: Limit/Home switch X-axis problem...
« Reply #3 on: May 22, 2007, 06:33:19 PM »
I solved my problem. I used the hardware approach. I reversed one motor on the driver. Thus I could use the working X-axis setup in Mach3.
However, the next problem was that once all three steppers work, there is so much noise on the line that there were a lot of triggers of limits.
So I switched them off again and ordered an opto coupled breakout board... Sighhhh..... It never ends... doesn't it 8).
Lemo
Cut five times and still to short...