Hello Guest it is May 19, 2024, 10:01:04 AM

Author Topic: Z axis problem with USB 6040z CNC /Mach3  (Read 2336 times)

0 Members and 1 Guest are viewing this topic.

Z axis problem with USB 6040z CNC /Mach3
« on: April 29, 2016, 12:37:50 PM »

I received my 6040 USB router from China earlier this week.

With the CNC I got an auto zero tool which seems to be good. But the issue I have is when running gcode it goes lower then it should. I have checked the code and that seems good. I tried a code with 4 holes with the same depth/diameter, the first one is fine but the second and third hole is going deeper and deeper. And the fourth hole cut right through the materials and into the aluminum bed.

To figure it out I have tested multiple times just setting the Z0 with both the "auto tool" and also without it.

It seems to work fine when I try hit the button "Go to Zero" first time after it's set to 0. But if I change the position and try to go back again it presses the drill trough the material. It seems that Z0 is lowered each time i push the button "Go to Zero", if I press it three times, it pushes through 20mm of material and in Mach3 it still says that the Z is 0, even though it's pressed into the PVC sheet.

When I look at the machine coords it is the same value each time as well.

Someone who knows what the issue could be?

Many thanks in advance!

Re: Z axis problem with USB 6040z CNC /Mach3
« Reply #1 on: April 29, 2016, 02:29:58 PM »
Post your profile XML and the gcode file and someone will have a look.

There is not enough info in your post above as it may be a few things

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”

Offline kolias

  •  1,154 1,154
    • View Profile
Re: Z axis problem with USB 6040z CNC /Mach3
« Reply #2 on: April 29, 2016, 06:28:04 PM »
You should also post the script file of the Auto Zero
Re: Z axis problem with USB 6040z CNC /Mach3
« Reply #3 on: May 01, 2016, 05:47:45 PM »

Thanks for your replies.

I tried switch motors of Z and X axis and that solved the problem. Must have been that the screws wasnt tightened enoough....