Hello Guest it is May 27, 2023, 10:43:37 PM

Author Topic: Parallel port for PCI bus that works with Mach3 - just passing along info  (Read 71774 times)

0 Members and 1 Guest are viewing this topic.

Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #40 on: January 13, 2015, 08:20:17 PM »
Thanks a lot and I will definitely check that out. But, right now I am spending all of my free time trying to get my current setup working. I will post my xml file and hopefully someone would be kind enough to take a look at it for me. I would greatly appreciate it. I have scoured this forum and tried every solution I could find on here, with no luck. Ill try to give as much info as I can:

Windows XP Pro 32bit fresh install fully updated
Addon Rosewill dual PP card rc-304
LPT2 0x9400 Only using port 1, and verified the port in ports and pins
x axis enabled pins 2 and 3, port 1
jog is on
I have the following green port lights on the diagnostics screen: three off five on and the bottom row is completely off

I am completely stumped.
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #41 on: January 13, 2015, 09:51:45 PM »
Ok, I think I have an update. I was messing with the port address, and have noticed that if i try the addresses in between the ones listed in the the resources tab of the device manger, that I can get different light combinations to light up in the diagnostics screen under the port 1 pins current state. But, the most I could ever get to light up at once was the first 7 of the top row and nothing on the bottom row. And this happened on any of the second numbers.

Here is what my device manger lists:

Multifunction Adapters
   PCI Mullti-IO Controller
I/O Range 9C00-9C07
I/O Range 9800-9807
I/O Range 9400-9407
I/O Range 9000-9007
I/O Range 8C00-8C07
I/O Range 8800-880F

Ports (COM & LPT)
   PCI Parallel Port (LPT2)
       Use any interupt assigned to the port (CHECK)
       Enable legacy plug and play detection(CHECK)
I/O Range 9C00-9C07
I/O Range 9800-9807
IRQ 16
   PCI Parallel Port (LPT3)
       Use any interupt assigned to the port (CHECK)
       Enable legacy plug and play detection(CHECK)
I/O Range 9400-9407
I/O Range 9000-9007
IRQ 16

Now that I have listed that, it might be easier to explain what I meant. Any of the second numbers ie 0x9407 gives me the first seven pins of the Port 1 current state. And this is the same for all of the second numbers. Anyone have any ideas?

Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #42 on: January 15, 2015, 07:26:49 PM »
Nevermind my cries for help. I got it working. Turns out that longs motor has exact directions on interfacing their breakout boards with Mach 3. The online chat support person had screenshots of all of the config settings. Now that my mind is at ease (for now) I will soon make a thread in the show and tell of my progress so far. Just to let everyone know, I have the longs motor 4 axis nema 34 1232 oz in. kit. So if anyone is interested I can list my exact details to make setting up your hardware with mach 3 much easier.
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #43 on: February 24, 2015, 06:52:04 AM »
Hey all.

I was smacking my head against a brick wall for 2 days trying to get mach3 working.
I got it working and so will place my input of how.

My Setup:
- mach3 v2.0
- dual pci parallel port (no brand off ebay $37...NEW PCIe PCI-E PARALLEL 1284 DB25 2 PORT CARD WORK WINDOWS 8 / 7 / DOS / LINUX. seller:chunwai_1996)
- Automated Tec package with: Gecko G540, nema23's an a nema34 + psu

- followed installation instructions here: http://www.geckodrive.com/support/application-notes/step-drives/g540-initial-setup-guide.html
installed the xml file from here: http://www.geckodrive.com/support/application-notes/step-drives/g540-xml-file.html
- got to the stage with the charge pump switched off, green led and stepper motor was on/locked.
- no communication with mach3.
- did research and found out how to set the parallel ports: http://www.hobbycncaustralia.com/Instructions/iI20PinsandPorts.htm
- didnt know whether to set the onboard parallel as enabled or disabled etc.
- tried numerous things like changing through all the ltp's and i/o's, no result.
- found I had windows 7 x64. Mach seemed to be working fine, but I got fooled.
- installed windows 7 x32 with stored 'windows old'
- reinstalled mach3, still didnt work
- formatted and did clean sweep of OS and installed windows 7 x32
- installed mach3. came up with a warning popup to install driver, hit ok. waited a couple of mins and it was successfully installed (no popup with x64 bit)
- in bios set the onboard to enabled, epp, left the other settings (even though I dont have an onboard port and installed a pci dual port)
- in mach 3 used the g540 xml,
- went through controll panel, device drivers, looked at the parallel port. it was listed as epc, i/o DD00, LTP2 ( i knew this was the one I was connected to because with the gecko and motors plugged in without charge pump, changing the LTP number made the steppers twitch)
- entered in those details to #1 port mach3
- I went into config ports/pins and unticked the e-stop on inputs and unticked the outputs charge pump (just to temp limit other possible hiccups)
- hit reset button... a popup warning appeared to do with the e-stop, clicked apply/ok,
- used arrow keys and finally it worked.

MAIN PROBLEM- windows 7 64 bit install, seemed to install drivers, but they dont work.
RESOLUTION- install windows 7 32bit FRESH. I had re installed with 'windows old'. This somehow got in the way when trying to reinstall mach3 and getting that driver working!

Tomorrow I will try running with charge pump re-enabled.

Thanks guys for all the chat, took me a while, but I think im nearly there.

Offline Lubby

  •  25 25
    • View Profile
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #44 on: February 25, 2015, 09:53:39 PM »
Was having issues with another (SPP/PS2/EPP/ECP) PCI parallel I installed.  Swapped it with the Rosewill RC-304 PCI card and got things working.

Most of the configuration info is already been covered in this thread.  My configurations hadn't really changed between one card and the next.  Just wanted to mention that not all cards that say EPP are created equal.  The RC 304 does work.  ( at least on an older DELL running XP )

Thanks for the posts.
I got the second parallel port installed and hooked up to a CNC4PC 10 BOB...Only getting 2.4v from all the inputs...

Edit: I added a 5v power supply and all is good now. ;D

Help a brother out! How did you add a 5V power supply? Add on with an inline BOB?

Offline Lubby

  •  25 25
    • View Profile
I ended up changing the parallel port and went with a fifth motor on that.  I don't have the BOB installed anymore so I'm going on memory.

I believe I used an external 5vdc power supply for the BOB.  I think you'd likely blow something if it were supplied inline through a parallel port pin ( unless the motor is incredibly small the current needed for the motor would be too high)

The control of the BOB was through the parallel port pins.

I believe I also shared the ground between the external power supply and the parallel port.  I forget the reason but there can be communication issues if there is more than one power source controlling electronics.  Sharing ground solves that.

Does this help?

Offline RICH

  • *
  •  7,428 7,428
    • View Profile
I just installed a Rosewill RC304 2 port Parallel PCI card. It does work. I read this complete thread and others in anticipation of having problems with the card installation. I used the drivers that came with the card, it did install, but, I had problems with Mach
recognizing the second port. So the follwoing is what I did:

0. Make sure you turn off / unplug the pc before attaching or removing any card!  :D

1.This info pertains only to the Rosewill RC-304.

2.Info is for an XP installation.
3.MY PCI slot is 5 volts only.The RC-304 is a 5 volt card. Some cards are dual voltage / universal cards.

4.The cable that connects to the card for the second pp must be attached correctly. Get it backwards
  and the card will not work correctly since the pins are all screwed up!
  The ribbon cable has one RED line on it, and if you look at the card you will see a white dot and also
  a white line near the cable connector. So connect the cable such that the RED line on the ribbon cable
  is also on the same side as that white line and dot.
5.I removed the existing single pp card and also uninstalled the drives for the card.
  This was done via System Properties>Hardware>Device Manager selecting Multifunction Adapters,
  select the device , double click on it and select Driver, and finaly click on the Uninstall option.
  You will see that the device is no longer listed and that under Ports(COM & LPT) no LPT is listed.

6.Reboot the pc and confirm item 5.

7.The RC-304 card came with instructions on how to install the card for Windows XP and listed the drivers
  in folder RC-302\WinXP.There was no folder by that name but there was a folder called RC-302\XP.
  ( So when the wizard prompts you for the location browse and select that folder as it said it could not
  find the file .......NmPar...........)

7a.It was noted by others that the drivers provided on the CD were no good. I downloaded from MOSchip site
   and other sites the drivers for the card. What I found was that the drivers provided on the CD were of the
   same name and date as all the other drivers that were downloaded. So I used the drivers from the CD.

8.Installed the card, pc found new hardware and followed the installation via the wizard manualy selecting
  the folder RC-302\XP. It installed the drivers, but, the LPT ports were LPT2 and LPT3, so I changed the
  the assigned LPT part number via:
  System Properties>Hardware>Device Manager>Ports,select the port and use the LPTport button to select the port   desired port number. Also ticked enabled plug and play detection, and also ticked Never use an interupt.

9.Click the Resources for each LPT and note the I/o Range settings available:
  For LPT1 they were: DC00-DC07   I used DC00 ( first number) for port 1 setting in Mach config
  Also used the first number listed for port 2 settng in Mach config.

10.NOW FOR THE PITA, part.........

   The second port would not work correctly for inputs I had defined to Mach in ports & Pins.
   Think i may have had the the ribbon cable backwards - GO BACK AND READ ITEM #4-.
   Also in Mach Diagnostics the lit LED's didn;t seem correct.

10a.So I uninstalled the card drivers using the file ....NmUninst....in the Rc-302\XP folder.

10b.Shutdown the computer, removed card, reboot and shut down again.

10c.Installed the card, and confirmed the correct ribbon cable orientation to the card.
    Reboot, it found the new hardware, but the install wizard didn't work worth a darn.
11.So...... I used the manual install method:
   Control Panel>Add Hardware>ticked that i have already installed the hardware,Selected PCI multi Io    controller, when asked for the driver i used the .....NmPar.... file, the card drivers were installed
   and LPT1 and LPT2 were assigned. ( I don't remember every single step in this item ).

Both ports work fine in Mach and now have pins 2-9 as inputs.

Note: In Mach config the first numbers for the resources were used, I first unticked the Port Enable,
      typed in the resource setting ie; DC00,Mach changed that to 0xdc00, then ticked Port enable.
      Did the same for Port 2.

PC'S suck sometimes.  :P :)

I also purchased a Rosewell PCI to parallel card (single design) for use in an XP Compaq tower with a damaged integrated parallel port on the motherboard. I installed the drivers and PCI board, reconfigured Mach 3 for the new port number and found that Mach 3 could not use the port. After beating my head against a wall for a couple of days, I discovered that the computer's BIOS would not allow the add on parallel to operate until I disabled the internal parallel port, even though the BIOS had no settings for and add on ports. Hope this helps somebody avoid the same headaches.

I have the exact same problem you had/have. When I uncheck pins 2-9 and hit apply then recheck pins 2-9 and hit apply.... my 2nd PP then works fine.  ITS CRAZY!!!

What was the answer or solution to this problem?

does anyone else have anything to say about this?
I too have struggled with getting a second printer port to work correctly.  I have an older SIIG with a NetMos 9835 chip and a newer card with the MosChip 9865.

I've updated the drivers and tried all sorts of stuff to get them working, but they still don't work right.

The one thing I have found that works for either card is as follows:

1.   Open the Ports and Pins Screen & set everything up in Mach (make sure both ports are enabled and the second port has the 2-9 inputs check-box selected.
2.   Close the Ports and Pins Screen.
3.   Re-Open the Ports and Pins Screen, deselect the 2-9 inputs check-box, click apply, reselect the 2-9 inputs, and click apply.
4.   Close the Ports and Pins Screen and everything works.

Each time I start Mach, I have to go through this process to get the second port to work.  When I first start Mach, the pins on the diagnostic screen are all lit up.  After going into Ports and Pins & toggling the 2-9 input check-box, the pins go out and everything works.

I know it sounds strange, but it works every time.  Could there be something strange going on with Mach?