Hello Guest it is January 21, 2022, 01:00:51 AM

Author Topic: Mach3 won't start my router.  (Read 1821 times)

0 Members and 1 Guest are viewing this topic.

Mach3 won't start my router.
« on: May 04, 2016, 09:35:27 PM »
I've been trying to get Mach3 to stop/start my router through a BOB connected through pin 17 to a SSR. I have the spindle relays activated and output 1 set to the proper port and pin.  I can get it to toggle on and off with the F5 key and with the spindle button.  When I try to run G Code command M3S20000 or M5 nothing happens. I have also tried to enter M3 and M5 in the diagnostic screen with no results.

I have read every post that I could find on the subject and am unable to find a solution.  Any help will be greatly appreciated.
Re: Mach3 won't start my router.
« Reply #1 on: May 06, 2016, 09:35:13 PM »
I solved the problem! 

In case this happens to someone else the solution was easy.  When I installed Mach3, for some reason the macro files were not copied to the profile I set up for my CNC Router. I copied the files from the Mach3 Mill file and pasted them in the CNC Router file. Every thing works as it should now. ;D

Offline Tweakie.CNC

  • *
  •  8,878 8,878
  • Super Kitty
    • View Profile
Re: Mach3 won't start my router.
« Reply #2 on: May 07, 2016, 07:43:57 AM »
I am pleased you solved the problem and got the spindle working as it should.
Thanks for posting the heads-up on the solution.