Hello Guest it is December 08, 2019, 02:27:47 AM

Author Topic: Ethernet Smooth Stepper spindle control problem  (Read 5528 times)

0 Members and 1 Guest are viewing this topic.

Ethernet Smooth Stepper spindle control problem
« on: January 14, 2016, 03:05:36 PM »
I currently have an issue when using my ESS to control spindle speed.  The VFD is on a 0-10v control voltage to control spindle speed, however, when requesting full speed in Mach 3 (should see 10v), I am only seeing 8.8 - 9v to the VFD.  I have replaced my BOB and the problem continues.  Is there a way to adjust the output voltage of the ESS or where else should i look?
Re: Ethernet Smooth Stepper spindle control problem
« Reply #1 on: February 19, 2016, 05:25:13 PM »
Hello, I realize that this is an older topic but perhaps you still are looking for an answer.  To the best of my knowledge the ESS does not (cannot) directly output the 0-10V signal necessary to control your VFD.  In my application the ESS output for spindle control is sent to a PWM variable speed controller (specifically this one http://cnc4pc.com/c41-pwm-variable-speed-control-board.html) which includes a small potentiometer to "calibrate" the voltage output (the orange "disk" in the lower center of the photo at the link).  To achieve maximum output voltage it was necessary to command the maximum desired spindle speed and then adjust the potentiometer until 10V was achieved.  I suspect that your application has a similar board to provide this function and likely has a similar calibration capability.

I hope this is of some help,

Steve