Hello Guest it is January 20, 2020, 12:26:21 PM

Author Topic: PLUGIN signals access via LUA?  (Read 2488 times)

0 Members and 1 Guest are viewing this topic.

Re: PLUGIN signals access via LUA?
« Reply #10 on: March 09, 2016, 07:47:59 PM »
Blockhead

I only need the pokey for a pendant I have the ESS for motion

Russ

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: PLUGIN signals access via LUA?
« Reply #11 on: March 09, 2016, 07:51:21 PM »
then you need to know what IO pins are active have you set the pokeys to IO only

Offline DazTheGas

*
  •  752 752
  • DazTheGas
    • View Profile
Re: PLUGIN signals access via LUA?
« Reply #12 on: March 10, 2016, 01:48:52 AM »
Quote
DAZ they are very interesting boards to use but the ESS is close to being as good

Sometimes i like to just play but i think this time i wont buy a pokeys as i will prob be playing loads with the ESS as there is an api being developed to access the ESS direct,"this will be cool"

DazTheGas
Theres always time for a choccy biccy
Re: PLUGIN signals access via LUA?
« Reply #13 on: March 10, 2016, 07:47:16 AM »
Blockhead,

Mapping fixed POKEYS input or output pins has not been an issue.  Mapping the Matrix Keyboard has been the issue.  Matrix LED works fine, but the keyboard is not working correctly.  I opened a ticket with Polabs who is investigating.

Russ
Re: PLUGIN signals access via LUA?
« Reply #14 on: March 11, 2016, 08:18:37 AM »
Well I have several push buttons on my pendant working in MACH4.  These are buttons in a keyboard matrix, so that aspect of POKEYS seems to be working for a few keys.  The first two keys in the matrix were Cycle Start and Feedhold.  As DazTheGas pointed out in another post on Feedhold this is a two step process.  Since Feedhold was not an input but an output you had to use an input and then put some code in the PLC script to send the feedhold command or cyclestart command when it sees that given input.  I am struggling to get that to work for Spindle Forward, Spindle Stop, Spindle Reverse buttons.  I actually copied the code from the Spindle clockwise button on the screen set and tried to add that to the end of the PLC script but that did not work.

The second issue I have is the MPG seems to be activated all the time.  Under the POKEY pendant configuration I do not have the JOGMPG enabled but as soon as I turn the MPG the axis moves.  I have dedicated switch inputs for the axis selectors and those work.  So if I select Z and turn the MPG it moves, the same for the other axis.  I have not been able to get the X1,X10,X100 matrix buttons to work yet.  I really wanted to have a button on the screen that would enable the MPG, similar to what MACH3 had when you hit the tab key.

Any suggestions?

Russ