Hello Guest it is December 15, 2019, 07:28:33 AM

Author Topic: DMM servos and Mach4  (Read 2264 times)

0 Members and 1 Guest are viewing this topic.

DMM servos and Mach4
« on: March 02, 2016, 11:59:38 PM »
I have recently converted my Jet 13x40 lathe equipped with DMM Tech servos from mach3 to mach4.  I have the DMM servos, BOB and drives work with Mach4 and the Smoothstepper.  Homing though isn't working right: X axis homing works but Z does not. I have the same setting in Mach4 for both axis except for the pins and name: Pin 10 for x homing/limit and 12 for z homing/limit. In diagnostics, you can see the lights work when you trigger the limit switch but when you try to home, Z homing does not work. It tries to home and then stops and does not back up, like x axis does. One other thing is that Z axis(Lathe profile) jogging is backwards when I push the jog buttons on the display with the mouse. x axis is proper direction. I don't know if these things are related and really am frustrated at this point.

Other than the homing issue, I am really liking Mach4.   I was able to cut a 1/2-20 thread- made the gcode with fusion360 and everything cuts well but the Homing issue is driving me nuts.

Any suggestions would be greatly appreciated.

FYI, here is the conversion thread when I set up the Jet lathe to cnc and Mach3:

http://www.hobby-machinist.com/threads/converting-a-13x40-manual-lathe-to-cnc-with-servos-and-mach3.33405/
Re: DMM servos and Mach4
« Reply #1 on: March 03, 2016, 12:37:31 AM »
One other thing is that Z axis(Lathe profile) jogging is backwards when I push the jog buttons on the display with the mouse. x axis is proper direction. I don't know if these things are related and really am frustrated at this point.
I can't help with the homing issue, though there have been several other posts on this forum about SmoothSteppers and homing that sound like you problem.

As for the Z axis jogging backwards - if the GCode motion is in the correct direction and only jogging is backwards, check the soft limits settings.  Go to the "Configure" menu and select "Mach...".  Then click on the "Homing/SoftLimits" tab.  Having the "Soft Max" value less than the "Soft Min" value will cause this behavior.  And since the "Soft Max" column is listed first (which is not what most people expect), it is a common mistake to presume that this is the "min" column.

Bob
Re: DMM servos and Mach4
« Reply #2 on: March 03, 2016, 11:39:35 AM »
One other thing is that Z axis(Lathe profile) jogging is backwards when I push the jog buttons on the display with the mouse. x axis is proper direction. I don't know if these things are related and really am frustrated at this point.
I can't help with the homing issue, though there have been several other posts on this forum about SmoothSteppers and homing that sound like you problem.

As for the Z axis jogging backwards - if the GCode motion is in the correct direction and only jogging is backwards, check the soft limits settings.  Go to the "Configure" menu and select "Mach...".  Then click on the "Homing/SoftLimits" tab.  Having the "Soft Max" value less than the "Soft Min" value will cause this behavior.  And since the "Soft Max" column is listed first (which is not what most people expect), it is a common mistake to presume that this is the "min" column.

Bob

Thanks for the suggestion.  FYI, I was given a tip on cnczone that fixed the direction issue: changing the z direction pin in the smoothstepper config menu from high to low changes the direction when you jog and fixed that.  Limit switch issue remains and the machine just homes till the switch triggers and then stops with the switch still lit.  I can hit reset and then jog off but it never ref homes for z only.

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: DMM servos and Mach4
« Reply #3 on: March 03, 2016, 12:24:50 PM »
check that your backoff setting in the ESS homing tab isnt set set too slow.

DazTheGas
Theres always time for a choccy biccy
Re: DMM servos and Mach4
« Reply #4 on: March 03, 2016, 02:37:38 PM »
check that your backoff setting in the ESS homing tab isnt set set too slow.

DazTheGas


I tried moving the backoff rate up but there was no change. I went as high as 30 even. 

 FYI, your videos really helped on setting up and getting the axis moving- thanks for putting that together.