Hello Guest it is March 20, 2023, 10:17:25 PM

Author Topic: HOMING ISSUE!!  (Read 1554 times)

0 Members and 1 Guest are viewing this topic.

Offline mry

  •  8 8
    • View Profile
« on: March 07, 2016, 05:39:25 PM »
i own a a retrofitted router with one stepper on y, one on z and two steppers on x (one is configured as axis a) ..

stepper A is configured to mirror stepper x.

machine works perfectly, and have run it for 3 years with NO home switches. and never a problem with crashes (i am careful!)

finally decided I need them to make my machine more reputable because I am doing some jobs over and over.. (to the point were I have Fixtures for the machine that I never saw in the beginning)


the machine has existing homing / limit swithes which are of the normally open type.
using these existing switches I wired the switches in parallel.. configured my inputs for X home , y home, z home and a home.
and tried homing

z works perfectly
y works perfectly
x however.. works half!
 one of my motors (we will call X, stops as it should)
the A motor however continues to run. even after the switch has been activated.

I have attempted to EMULATE the a axis home switch,
I have tried to disable and enable and reverse the a axis..
but I am slowly tearing the machine apart during this home cycle..

can anyone think of a reason why my axis motor would continue to run forward after the limit switch on the x axis has been tripped.

Offline mry

  •  8 8
    • View Profile
« Reply #1 on: March 07, 2016, 06:31:19 PM »
somehow "Home Slave with Master" was not selected from general config..

« Reply #2 on: March 09, 2016, 11:19:39 AM »
Tried to get a good pic but the white box is the soft limits for my machine. So basically my boundaries of where I can cut. While the intersection of the purple lines is suppose to be your machine home. So I have to set up the home limits my working space is only at home because I put it there. So when I load a Gcode in it sets the blue piece on the picture at home. I'm guessing my home is not set right ?idk still trying to figure it out. Anyone have any suggestions or help