Hello Guest it is June 17, 2019, 03:30:49 AM

Author Topic: Mach 3 PWM signal inverted?  (Read 4781 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 3 PWM signal inverted?
« Reply #10 on: February 25, 2016, 12:38:19 PM »
Sorry Joe.
SmoothStepper (in your XML) or Printer Port.
Re: Mach 3 PWM signal inverted?
« Reply #11 on: February 25, 2016, 12:57:04 PM »
I use an ethernet SmoothStepper.

Joe
Re: Mach 3 PWM signal inverted?
« Reply #12 on: February 25, 2016, 02:55:00 PM »
Most likely, but do you have the spindle configured there as well ?
Re: Mach 3 PWM signal inverted?
« Reply #13 on: February 25, 2016, 03:14:07 PM »
I don't have a spindle on this machine.  I have a Blacktoe 2' X 4' CNC router to build most things.  I use the Shapeoko3 for laser only.

Joe

Offline BR549

*
  •  6,871 6,871
    • View Profile
Re: Mach 3 PWM signal inverted?
« Reply #14 on: February 25, 2016, 04:37:23 PM »
Good Luck Russ ,   ;)
Re: Mach 3 PWM signal inverted?
« Reply #15 on: February 25, 2016, 06:29:04 PM »
I don't have a spindle on this machine. 
Joe

So then, what is the SuperPID Spindle controller for ? to run the laser ?
I'm (more) confused.  ::)
Might should back up a bit and provide a bit more info.
I did see some similar issues posted on the Warp9 forum, you might look there too.

Russ

TP, please pass that bucket o' corn.  :)
Re: Mach 3 PWM signal inverted?
« Reply #16 on: February 25, 2016, 09:15:24 PM »
I am using a Blacktoe router, Mach3 software, a Smoothstepper ethernet converter, A14A breakout board, Super PID controlling a Porter Cable router speed.  Everything works except the PWM pulse to the PID is inverted meaning that I get a high PWM going low for slow speed and that is backward from what the PID needs.  My whole problem is that I cannot find a way in Mach3 to change the PWM pulse to be low going high to get slow speed.  It wants to get S25000 to achieve a speed of 5000 rpm which is wrong and a S5000 to get a 25000 rpm.

This used to work fine but some setting is wrong and no one can tell me which setting.  The Output tab in Mach3 is set to Output #2 Pin 14 with active checked or Xed and nothing changes.  I could build a inverter circuit but that is not the correct way to get the right PWM out of Mach3.

Why doesn't changing the active high to low or back change the PWM pulse to low going high?  When this is changed it shows up in the Mach3.html file correctly but no change in PWM.

Joe
Re: Mach 3 PWM signal inverted?
« Reply #17 on: February 26, 2016, 12:30:44 AM »
Most likely, but do you have the spindle configured there as well ?

I'll rephrase that as I think I might have confused us. ::)
Have you configured the PWM settings in the Smoothstepper accordingly?
You most likely did, just confirming.

Also, the only other thing I see that appears contrary to the manual is the Spindle direction pin should be 0.
May be a conflict with your pin1 selection for the CW and CCW relay selection.
Might ... or might not matter. Worth a try though.

Regards,
Russ
Re: Mach 3 PWM signal inverted?
« Reply #18 on: February 26, 2016, 08:09:08 AM »
My Smoothstepper  config is set correctly.  The output is set correctly and changing the check box to 'X' does not change anything.  That is the problem why?

Joe
Re: Mach 3 PWM signal inverted?
« Reply #19 on: February 26, 2016, 08:35:47 AM »

This used to work fine ................................

You might reconfigure to another/different output pin. Looks like 17 is available.