Hello Guest it is December 16, 2019, 06:21:27 AM

Author Topic: Gcode buffering?  (Read 1153 times)

0 Members and 1 Guest are viewing this topic.

Offline olf20

*
  •  318 318
    • View Profile
Gcode buffering?
« on: February 20, 2016, 11:23:05 AM »
We are running mach3 ESS with designated version and updates.
Some times when we run a file (in air) we need to make a tweak.
We will hit feed hold, stop, rewind and have the program take us to
0,0,0.
Then when we reload the program, or a different one the mill
will make a strange move as if there is some code left???
Any thoughts how to clear out any code?
It does not do it every time.
ESS or Mach problem.
Thanks for any help!
olf20 / Bob
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998
Re: Gcode buffering?
« Reply #1 on: February 20, 2016, 01:21:08 PM »
Check to see the current work offset when this happens.
Perhaps your various files are in different offsets.
Or maybe a G52 is in there somewhere.
Just guessing.
Russ

Offline olf20

*
  •  318 318
    • View Profile
Re: Gcode buffering?
« Reply #2 on: February 21, 2016, 07:23:45 AM »
No G52 in any of the code. Will see what the work
offset is next time it happens.

 I must say that the old mill is running great.
We had a fire two years ago and the mill was
the last thing to get back up and running.
I have been machining parts for a friend who is
building a new router table and the side plates that
have all the holes to bolt it together line up perfectly.
Thanks
olf20 / Bob
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998