Hello Guest it is November 15, 2019, 03:33:08 PM

Author Topic: Video window wont open on windows 10  (Read 1033 times)

0 Members and 1 Guest are viewing this topic.

Video window wont open on windows 10
« on: February 01, 2016, 08:46:22 AM »
So, Had an XP machine in place, running my mill.  Ran flawless for YEARS.  Still does.
Only had 2 gig of ram, Also tried running camtasia to record the screen while making a video for someone to help them out.
Mach did not like that.

Put a much beefier machine in place
windows 10.
Copied the mach3 folder from the XP machine to the windows 10.
Downloaded .060 and installed.
Installed the USB SS drivers.
Boom mach3 talks, works, homes jogs ect.
Plug in my usb camera, Try to open the video window.  Nothing.
Come into my office.  Windows 10 machine with mach installed.
Tried to open the video window......... There is a quick flash and nothing.

Downloaded Klaus's video plugin and can get a video window to come up.
Legit mach3 license. USB SS.
Also tried with a logitech webcam.  Windows 10 automatically installed the drivers.  Video port wont open, works with the Klaus plug in.

Any ideas?

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Video window wont open on windows 10
« Reply #1 on: February 05, 2016, 10:38:25 PM »
Just some thoughts....

Have you proven that the camera is still working outside of Mach3?

It might just be a "co-inky-dink" that it's no longer working (as of at the moment you tried to use it with Mach).

I've certain that some peripherals that were working in XP don't work in 10.

Might be that the video driver for the camera doesn't work in 64bit.

Might be that you need to get a later manufactured camera whose driver says Windows 10 compatible.

Go back to the XP machine if it's still working and verify that the camera is still okay.

I wouldn't rely on Windows 10 to have a "plug and pray" driver even if it is an older camera.
Re: Video window wont open on windows 10
« Reply #2 on: February 06, 2016, 12:16:07 PM »
yes the camera works, the Klaus plug in works and I get video,   Also the same camera on an XP machine works with the stock video window in mach.