Hello Guest it is June 21, 2021, 12:21:51 PM

Author Topic: over my head in 4th axis  (Read 1478 times)

0 Members and 1 Guest are viewing this topic.

over my head in 4th axis
« on: January 10, 2016, 06:46:27 AM »
Hi my names Jon just added 4th axis to 3 axis router purchased 4th axis 6:1 step reduction ratio nema 23 stepper motor and 3.0 motor driver micro stepping 1 to 1/64. So I got this sucker all plumbed in I have movement and allot of it. I'm not sure if I have the driver set right butt its working. I've got A rotation turned on and A set to linear am I missing something in motor tuning? any help would be fantastic

Offline Tweakie.CNC

  • *
  •  8,715 8,715
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: over my head in 4th axis
« Reply #1 on: January 10, 2016, 06:55:44 AM »
Not much help but an A axis is usually set to angular, in that way any Gcode commands represent degrees of rotation (assuming you have the steps per unit set correctly).

The Mach3 manual explains in more detail about the steps per unit setup   http://www.machsupport.com/help-learning/product-manuals/


Offline ger21

  • *
  •  6,292 6,292
    • View Profile
    • The CNC Woodworker
Re: over my head in 4th axis
« Reply #2 on: January 10, 2016, 07:28:22 AM »
You also need to configure the a axis steps per unit as steps per degree.

2010 Screenset

JointCAM Dovetail and Box Joint software

Offline BR549

  •  6,952 6,952
    • View Profile
Re: over my head in 4th axis
« Reply #3 on: January 10, 2016, 05:16:40 PM »
Also your Microsteps are way too high to be practical . It should be set for 10 at most.  

A axis is angular

Steps per are in degrees

To test set teh A axis to A0.000 then call a G0 A360 and the A should physicaly make 1 exact rotation.

(;-) TP
Re: over my head in 4th axis
« Reply #4 on: January 12, 2016, 05:39:28 AM »
the quick and dirty version.
A axis is angular, as said above.
microstepping no more then 10
Zero A axis
use MDI to rotate 360 degrees  (G0 a360)
if it goes past 360 degrees then your steps per in motor tuning is to high. 
if it rotates less then 360 degrees then steps per is to low.
Change your steps per for the A axis, click the "SAVE AXIS SETTINGS BUTTON"
back in mach, zero the A axis work cords.  they will change.
repeat steps.

I will also mention that i have had an A axis velocity set really high once.  The axis would run smooth at 3000 mm a min.  All other axis were set to 600mm a min.  When running a 3d toolpath I would get missed/lost steps.  Tracked it down to be that the difference in the A axis velocity.  So tune the A axis close to the other 3