Hello Guest it is July 07, 2020, 03:57:35 PM

Author Topic: mach 3 axis not running as DROs  (Read 5564 times)

0 Members and 1 Guest are viewing this topic.

Re: mach 3 axis not running as DROs
« Reply #10 on: January 06, 2016, 07:05:43 AM »
Yep, sorry for the size of the video, I saw it when it was already uploaded :( next time will use Youtube
and Yep - You were right, on all 4 pins (3,5,7 and 9) it gave 3.32. I suppose that it is not strange that the voltage stays this way until I use the other direction.
So, I need a new card, which is a good thing, I think :)
Will update once I get a new card.

Thx again!
RC Nikkie
Re: mach 3 axis not running as DROs
« Reply #11 on: January 07, 2016, 03:34:02 AM »
OK,
I got a card, should I know uninstall the driver of the mainboard, or leave it that way? I have a driver for the card, but which one to use - mach's one or the one downloaded?
RC Nikkie

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: mach 3 axis not running as DROs
« Reply #12 on: January 07, 2016, 03:45:31 AM »
I would be inclined to fit the card, let Windows find it and install it's own driver or insert the driver disk only if it asks for it.
May not be the right way to do it but, if it's any help, thats what I would do.

Don't forget to check the port address.  ;)

Tweakie.
KEEP SAFE !
Re: mach 3 axis not running as DROs
« Reply #13 on: January 07, 2016, 04:23:22 AM »
Ok,
I got the driver installed, what should I put as a port address (device manager says cc00) in mach 3 - cxc00, 0xc00, or what?
RC Nikkie

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: mach 3 axis not running as DROs
« Reply #14 on: January 07, 2016, 04:47:35 AM »
Just type in  cc00  then click OK  ;)

Tweakie.
KEEP SAFE !
Re: mach 3 axis not running as DROs
« Reply #15 on: January 07, 2016, 05:01:29 AM »
Yep!
I tried that just after I wrote the reply, feeling a bit silly now :), so I wrote it, clicked OK, everything is going great, just as it is supposed to be :)

Thank You, Tweakie!
RC Nikkie

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: mach 3 axis not running as DROs
« Reply #16 on: January 07, 2016, 05:37:38 AM »
That's great news, I am pleased you have it working OK now.

Tweakie.
« Last Edit: January 07, 2016, 09:08:37 AM by Tweakie.CNC »
KEEP SAFE !

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: mach 3 axis not running as DROs
« Reply #17 on: January 07, 2016, 09:10:06 AM »
You mentioned, back in post #8, the behaviour of the Ref All Home button. As standard this references each axis in turn (one at a time) and because of the design of your machine this behaviour is not suitable.

Referencing axes is not a procedure I ever need to use so I am no expert here – you will perhaps need to study the Mach manual http://www.machsupport.com/help-learning/product-manuals/ to get a grip of setting-up homing and using offsets but you may wish to consider making the following changes to the script in the Ref All Home button. Click Operator / Edit Button Script and then click the now flashing Ref All Home button. This will display the existing script. Delete all the existing script and insert…

                                            RefCombination(5)
                                            RefCombination(10)

Save the changes. This button will now reference your axes in their matching pairs X/Z and Y/A (and hopefully not break the wire).

Tweakie.
KEEP SAFE !
Re: mach 3 axis not running as DROs
« Reply #18 on: January 09, 2016, 06:29:06 AM »
Tweakie,
Thank You SO MUCH! Now axis are reffing home beautifully! Be prepared for some pics and video soon (in the apropriate themes offcource :) )
RC Nikkie

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: mach 3 axis not running as DROs
« Reply #19 on: January 09, 2016, 10:22:19 AM »
I look forward to seeing your pictures and video  :)

Tweakie.
KEEP SAFE !