Hello Guest it is August 08, 2020, 06:19:29 AM

Author Topic: Double config parameter in default Plasma.xml  (Read 1033 times)

0 Members and 1 Guest are viewing this topic.

Double config parameter in default Plasma.xml
« on: December 26, 2015, 08:53:47 PM »
Hello,

i have notced the following:
After installing the currently available download (Mach3Version3.043.066) and selecting the Plasma profile in the install I tried to change the pins for the motor drivers. (Testing the program with a paralell port BOB.) I was able to make the needed changes but it seemed that is has no effect on the actual pins the program uses. Then I digged into the used Plasma.xml when I noticed that there are two sets of config options for the same purpose. One uses the [XYZABC](DirPort|DirPin|StepPort|StepPin|StepNeg|DirNeg) naming convention and the other uses Motor[0-6](Active|DirNeg|DirPort|DirPin|StepNeg|StepPort|StepPin). The Ports and Pins window changes the later (Motor0-6) but the program actually uses the first set.

Does anyone have the same experience?

Next time i'm at the machine site i'll try to remove one of the config sections and try again.

Thanks,
metro
Re: Double config parameter in default Plasma.xml
« Reply #1 on: January 03, 2016, 10:16:39 AM »
Hello,

Just for the record: I have manually removed all the XDirPin, XStepPin, XStepPort, etc. config lines from the Plasma.xml and checked the configuration again in the Port and Pins.
After this, everything was OK, all my configuration changes took effect.

Thanks,
metro