Hello Guest it is November 18, 2019, 08:30:21 AM

Author Topic: M11P1 and M10P1 problem...  (Read 7930 times)

0 Members and 1 Guest are viewing this topic.

M11P1 and M10P1 problem...
« on: January 03, 2016, 06:11:18 AM »
hi my friends,
sory for my bad english :)

i use mach3 with homemade co2 laser machine...
laser enable signal on port1
when i use m3 and m5 commands are delaying..
i did search in forum and find the M11 and M10

i did write command line M3 and enter flash output1 led on Diagnostics screen;

BUT

when i did write command line M11P1 and enter not working....

can you help me??

regards...
Murat






Offline Tweakie.CNC

*
  • *
  •  8,002 8,002
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M11P1 and M10P1 problem...
« Reply #1 on: January 03, 2016, 06:33:29 AM »
Hi Murat,

Two things you need to consider…

If you are using Output#1 to trigger your laser then do not use Output #1 for your spindle relay control (M3,M4,M5).

The commands M11P1 (turn Output#1 ON) and M10P1 (turn Output#1 OFF) only take effect upon axis (any axis) movement.

So to operate your laser you would need something like this…

M11P1
X10
M10P1
X0
%

There are more details in the laser thread here;  http://www.machsupport.com/forum/index.php/topic,12444.0.html

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: M11P1 and M10P1 problem...
« Reply #2 on: January 03, 2016, 07:26:03 AM »
Hi Murat,

Two things you need to consider…

If you are using Output#1 to trigger your laser then do not use Output #1 for your spindle relay control (M3,M4,M5).

The commands M11P1 (turn Output#1 ON) and M10P1 (turn Output#1 OFF) only take effect upon axis (any axis) movement.

So to operate your laser you would need something like this…

M11P1
X10
M10P1
X0
%

There are more details in the laser thread here;  http://www.machsupport.com/forum/index.php/topic,12444.0.html

Tweakie.



Thanks for quick reply Tweakie...
i following to you....

i try now but i could not :(
i did use idle port 2..

x axis do movement but do not on laser... :(


M11P2
X1000
M10P2
X0

Offline Tweakie.CNC

*
  • *
  •  8,002 8,002
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M11P1 and M10P1 problem...
« Reply #3 on: January 03, 2016, 07:47:53 AM »
If these are your settings…
Laser trigger connected to Port2  Pin1

 

Set Output#2 (Ports & Pins) to Port2  Pin1

M11P2
X10
M10P2
X0
%

The above code will turn the laser trigger ON (during the X10 move) and OFF at the end.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: M11P1 and M10P1 problem...
« Reply #4 on: January 03, 2016, 08:08:56 AM »
If these are your settings…
Laser trigger connected to Port2  Pin1

 

Set Output#2 (Ports & Pins) to Port2  Pin1

M11P2
X10
M10P2
X0
%

The above code will turn the laser trigger ON (during the X10 move) and OFF at the end.

Tweakie.



yes i set this configrations

set output#2 = port2 = pin1

and gcodes :
M11P2
X10
M10P2
X0

x moving 10 but not laser trigger on :(

Offline Tweakie.CNC

*
  • *
  •  8,002 8,002
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M11P1 and M10P1 problem...
« Reply #5 on: January 03, 2016, 08:23:23 AM »
In Ports and Pins do you have Output#2 Enabled and is the Active High / Low set correctly for your laser ??

Do you actually have a second parallel port (Port2) card in your PC and is it configured to the correct port address within Mach3 ??

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: M11P1 and M10P1 problem...
« Reply #6 on: January 03, 2016, 09:31:42 AM »
connection is correct..
i added video;

https://youtu.be/sif4QrBb8W8

Offline Tweakie.CNC

*
  • *
  •  8,002 8,002
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M11P1 and M10P1 problem...
« Reply #7 on: January 03, 2016, 10:52:56 AM »
You may need to contact the manufacturer of your DDCM6 to check but (like many of the chinese cards) as far as I am aware it does not support the M10 / M11 command set.

If you attach your .xml file I can check your set-up and may be able to suggest alternatives for correct laser operation.

Your .xml file is located in the Mach3 folder and is named <your profile>.xml (Typically Mach3Mill.xml). You will need to rename it to something unique (ie. Enrique.xml) to be able to post it (using the Additional Options tab).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: M11P1 and M10P1 problem...
« Reply #8 on: January 03, 2016, 11:45:22 AM »
Thanks Tweakie....

my settings file and motion card user manuel is attach...

Offline Tweakie.CNC

*
  • *
  •  8,002 8,002
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M11P1 and M10P1 problem...
« Reply #9 on: January 03, 2016, 12:08:59 PM »
I have sent you a PM.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.