Hello Guest it is March 25, 2023, 03:28:07 PM

Author Topic: Help with Mastercam to Mach post error.  (Read 7222 times)

0 Members and 1 Guest are viewing this topic.

Help with Mastercam to Mach post error.
« on: December 08, 2015, 04:39:39 PM »
I downloaded the generic post for Mastercam from the Mach3 download section for posts.  The post is in the post file in Mastercam.  After I drew some lines, I tried to post to Mach3 and got this error message and wouldn't let me put it in the NC file of Mastercam.  "Error, illegal character $ on left side of equation post line number 215---Program halted due to error"  I have not a clue on how to fix this, can someone help?  Also, Most post files also have a machine difintion file and a control definition file, 3 files having to do with a post, and all that was in the Mach3 post download was a .pst file.  Do I need the other two files for the post to work in Mach3 and Mastercam.  I have Mastercam 9.1.  Really need some help. Bob.
Re: Help with Mastercam to Mach post error.
« Reply #1 on: December 09, 2015, 06:32:16 PM »
OK, I am using the generic post out of Mastercam 9.1 and it appears that it is working correctly.  The test Gcode routine that I drew works fine, so it appears that after some setting changes, such as the incorrect choice of setup units, namely mm. instead of inches caused a problem in the Gcode, I guess, because I changed over to the inches  and recalibrated, and it  ran flawlessly., So, I guess my problem is solved, thanks. Bob.