Hello Guest it is April 22, 2019, 02:51:30 PM

Author Topic: Homing LURCH issue, Mach3  (Read 1126 times)

0 Members and 1 Guest are viewing this topic.

Homing LURCH issue, Mach3
« on: November 12, 2015, 02:28:45 PM »

Ok, so this is weird.  Both X and Z axis' home just fine.  They travel to their switch, stop, then back off the switch, just as advertised.  Great!

The Y axis is another story.   When any of its Ref buttons are clicked, the machine either lurches, bumps, or travels a very short distance towards the home switch, and stops.  Sometimes it does absolutely nothing.  Sometimes all I notice is a thud, ie the servo did something, but no detectable movement.  Other times it moves up to an inch.  Wow!  But never has it traveled to the home switch.

When in operation all 3 axis' work just fine.  The only issue is Y axis homing. 

Settings:

The diagnostics screen shows the Y axis Port Pin and M2Home leds lighting up together.  X and Z have different Port Pin leds paired with M1Home and M3Home.

The Input Signals screen shows X Home on Pin 13, Y Home on Pin 15, and Z home on Pin 12.

The limit switch settings have been disabled until the homing issue is resolved.

All 3 axis' are set to “Home Negative” and “Auto Zero”.   And there are no slave axis'.

I've tried switching the pins on the BOB, but find the Y axis still misbehaving.

There are NO running Brains.

No errors anywhere.  The Configuration Check Facily is clean as is the error status sine and popup window.

Haven't found anything similar on the forum, so HELP anybody.  It's driving me nuts.  There must be some setting buried on or under some screen that I missed.

Thanks...

Online ger21

*
  • *
  •  6,206 6,206
    • View Profile
    • The CNC Woodworker
Re: Homing LURCH issue, Mach3
« Reply #1 on: November 12, 2015, 06:15:54 PM »
Is the Axis Ref'd LED lighting up, and are the machine coordinates zeroing?
Try increasing the debounce to maybe 5000 (just for testing) and see if it makes a difference.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Homing LURCH issue, Mach3
« Reply #2 on: November 14, 2015, 07:36:06 AM »
Gerry
I replied a couple of days ago... not sure where the post went.

Thanks for the reply.  That worked!  Y axis now moves as it should.

The debounce was set to 0.  Set it to 500, and that helped, but the axis would stop short of the switch.  Kept increasing till it reached 5000, and all works properly now.  Have begun to work on noise issues for a more permanent solution.

Thanks again....

   Jon
Re: Homing LURCH issue, Mach3
« Reply #3 on: November 14, 2015, 08:17:26 AM »
check your cable routing ... do the switch cables run past the motor power cables?

The X and Z seem to be working fine, and given the homing procedure is done one axis at a time it may be something wrong with the Y axis motor or driver creating noise which is affecting the switches / sensors.

you may have a motor with a winding issue or you may have a drive with a problem...

if possible (i.e. your motors are similar) try to swap your motors between drives and see it the problem occurs again:
(i.e. did it stay on the Y .... in which case it's the drive maybe, or
did it move to the other axis now.... in which case it may be the motor or wiring / routing etc)

may want to consider shielded cable for the sensors and drives (just make sure you ground the shielding only at one end)
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Homing LURCH issue, Mach3
« Reply #4 on: November 14, 2015, 09:27:46 AM »
Thanks for that Robert!  The motors and drives work properly, in that the machine actually produces accurate parts. The other odd thing is that X and Z home switch cables run through a cable chain tightly bundled with all kinds of power cables including the 5hp spindle cables.  The Y axis home switch cable is only about 3 feet long, yet it is the only problem child.

...... brainstorm .. 30 minutes later

OK Problem solved.  The 4 conductor cable that connects the Y axis home switch WAS shared with the tool height switch.  2 for the Y home switch and 2 for the tool switch. Just to eliminate all the possibilities, I clipped the wires that connect the tool switch, and now Y homes as it should, even after lowering the debounce to 5.  I don't get that at all!  But whatever.  Hopefully the problem with not return after a separate cable is run to the tool switch.  :)

Thanks again to you and Gerry for the suggestions.

  Jon