Hello Guest it is November 20, 2019, 05:50:01 PM

Author Topic: yesterday Y axis home works, today....  (Read 2395 times)

0 Members and 1 Guest are viewing this topic.

Re: yesterday Y axis home works, today....
« Reply #10 on: November 08, 2015, 06:02:57 AM »
Can I make a suggestion on your production XML file...

Your Axis are running as follows:
X-Axis = 12700 steps / inch, with a maximum velocity of 59.064" / min, so that is ~12.5kHz,   [59.064 / 60 x 12700]
Y-Axis = 12700 steps / inch, with a maximum velocity of 59.064" / min, so that is ~12.5kHz,   [59.064 / 60 x 12700]
Z-Axis = 12700 steps / inch, with a maximum velocity of 38.378" / min, so that is ~8.1kHz,   [38.378 / 60 x 12700]

Now when you look at the ESS Config, you have
X Axis = 32kHz (ok, that's the minimum setting)
Y Axis = 32kHz (ok, that's the minimum setting)
Z Axis = 4MHz .... suggest this is changed to 32kHz
In fact I'd suggest changing them all to 32kHz (even the axis not used, just in case the ESS sets up a loop at those frequencies regardless of if the axis is enabled or not, as it will do no harm).

There is now a good explanation here on the Warp9 website (suggest reading the rest of the whole page too as it's more informative than the manual ever was):
http://www.warp9td.com/index.php/faq/f-a-q-mach3#MachThreeStepFreq

Your controller frequency is set to 250hz... you may wish to improve that to 1khz (unless your PC is not up to it), again there is an explanation on the Warp9 website here (actually above the post I listed above... hence suggest you read the whole page
http://www.warp9td.com/index.php/faq/f-a-q-mach3#MachThreeControllerFreq


You also have debounce set on the Mach3 Config page.... but if you want debounce with the ESS... you need to set it within the ESS config ... explanation here:
http://www.warp9td.com/index.php/faq/f-a-q-mach3#Debounce


And finally you have the lookahead set at 20 lines on the mach3 general config page (but as I noted above you have the ESS controller frequency set at 250hz (~4 second buffer) ... so it's looking for a buffer, but mach3 is only looking at 20 lines for the motion planner ... suggest increasing this to 200 lines... bit of a guide here too for you to read (some of the other settings may be worthwhile to know about even if you don't use them:
http://www.machsupport.com/wp-content/uploads/2013/02/Mach3_CVSettings_v2.pdf


Hope it helps

Rob
« Last Edit: November 08, 2015, 06:09:52 AM by robertspark »
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”