Hello Guest it is April 19, 2019, 05:06:20 PM

Author Topic: Backlash when enabled, kills everything.  (Read 2291 times)

0 Members and 1 Guest are viewing this topic.

Backlash when enabled, kills everything.
« on: October 24, 2015, 03:07:58 PM »
Hello all.  I've been noticing some egg-ish pockets when they are supposed to be round.  I have a Taig mill and am wanting to apply backlash compensation.  Following bits and pieces on various posts here and there have been doing the following steps. 

Going into General Config and deselecting CV Dist Tolerances and Stop CV on Angles.  Then Selected CV instead of Exact Stop and then set shuttle Accel. speed to .05.  Click OK and then Config>save settings. 

Then go into Config>backlash.  Input for X .0012 and Y .0035, set backlash comp speed to 50% and then enable>OK then close out of Mach 3 and restart.

After restart, I got back to General Settings and set CV Distance tolerance to 180 (was the default amount) and set Stop CV on angles >90 (will need to see how the values effect things).  Then OK and then Config> save settings. 

After doing all that, no axis will move.  The DRO will change but there is no movement of any of the 3 steppers. 

Ill keep hunting for clearing directions on setting this up, in the meantime I would greatly appreciate any help.

Thanks, Pete
Re: Backlash when enabled, kills everything.
« Reply #1 on: October 24, 2015, 04:09:07 PM »
Also,

All in all, I am not sure if CV mode is even necessary for the backlash compensation to work.  I was just following along with a post on CNCzone, and also the Mach3_CVSettings .pdf I stumbled upon.  But is seems, like with Hoss's youtube video, it is simply a process of filling in the backlash window parameters and that's it. 

BTW, running latest version of mach3, 066. 

Pete
Re: Backlash when enabled, kills everything.
« Reply #2 on: October 25, 2015, 06:45:13 AM »
First of all, drop Mach3 back to V.062 - that works, but V.066 has strange things...

Cheers
Roger
Re: Backlash when enabled, kills everything.
« Reply #3 on: October 25, 2015, 09:15:49 AM »
Ok Roger, I'll try that for sure.  Maybe doing that will also clear up a multitude of other bugs.

What about the other settings and whatnot I posted here?  Am I correct in what I did? 

Pete
Re: Backlash when enabled, kills everything.
« Reply #4 on: October 25, 2015, 04:18:14 PM »
To be honest, i don't know. I don't use the backlash 'features', and frankly I don't trust them. I do use CV, but I think the settings for that must be the default ones.

Quote
The DRO will change but there is no movement of any of the 3 steppers.  
IF the DRO is changing, that would suggest that Mach is outputting the pulses. So I would do something like checking the power supply fuse. The problem would appear to be 'downstream'.

Cheers
Roger
Re: Backlash when enabled, kills everything.
« Reply #5 on: October 25, 2015, 04:50:23 PM »
Roger,

I've downloaded V.062 and will install and try tomorrow. 

As far as the DRO change and move stepper movement, I thought power supply first as well, but as soon as I deselected the enable backlash checkbox and restarted Mach3, the motors worked fine. 
Select the checkbox and the motors won't work. 

All in all, I hope the earlier version will help.  And maybe cure some of the persistent bugs I have.

Pete 
Re: Backlash when enabled, kills everything.
« Reply #6 on: October 25, 2015, 05:18:57 PM »
Hi Pete

All velly strange ...    Dunno.
V.062 works fine for me. Let us all know how you go?

Cheers
Roger

Offline Chaoticone

*
  • *
  •  5,472 5,472
  • Precision Chaos
    • View Profile
Re: Backlash when enabled, kills everything.
« Reply #7 on: October 26, 2015, 10:39:21 AM »
Pete, what are your step and direction pulse durations set to in motor tuning? Might want to have a look at those and/or sherline 1/2 pulse mode.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Backlash when enabled, kills everything.
« Reply #8 on: October 26, 2015, 12:00:46 PM »
Chaoticone,

Step and Direction are both 0 on each axis. 

Pete
Re: Backlash when enabled, kills everything.
« Reply #9 on: October 26, 2015, 02:00:33 PM »
Roger,

Just did a complete new install of V.062.  Did a complete uninstall to include deleting the Mach3 folder from C:.  Installed V.062, copied over the .xml files to the Mach3 folder and the plugins as well.  Mill works as it did before.  BUT again, as before with V.064, the backlash enable kills the motors.  Deselect the checkbox and again the mill will work. 

Frustrating issue for sure.

Pete