Author Topic: Backlash when enabled, kills everything.  (Read 2250 times)

0 Members and 1 Guest are viewing this topic.

Offline PW8697

  • Active Member
  • Posts: 51
    • View Profile
Re: Backlash when enabled, kills everything.
« Reply #10 on: October 26, 2015, 02:39:48 PM »

Just found out something interesting.  I have two laser systems, both use the Xulifeng-Mach3-USB-Motion-Card.  They work fine with Backlash Compensation enabled or not.  So, it has boiled down to the MK3 interface board and/or its drivers.  I have contacted the company to see if there are updated drivers for the board.  Otherwise I will get another Xulifeng board for my mill, as the other two are totally bulletproof and have had no problems with them at all. 

Will keep you posted on what happens. 

Pete

Offline rcaffin

  • Active Member
  • Posts: 990
    • View Profile
Re: Backlash when enabled, kills everything.
« Reply #11 on: October 26, 2015, 04:26:53 PM »
Quote
Step and Direction are both 0 on each axis. 
Doesn't that mean the step and dir signals are going nowhere? Shouldn't they be assigned to some pins so they go out to the motor drivers?

Cheers
Roger

Offline PW8697

  • Active Member
  • Posts: 51
    • View Profile
Re: Backlash when enabled, kills everything.
« Reply #12 on: October 26, 2015, 07:42:08 PM »
Roger, don't know what those numbers in Step pulse and Direction Pulse do in the motor tuning window.  Mill has been running fine all along, so signals are getting to where they need to.  Except with backlash compensation enabled, at least on this interface board.  

Pete

Offline rcaffin

  • Active Member
  • Posts: 990
    • View Profile
Re: Backlash when enabled, kills everything.
« Reply #13 on: October 26, 2015, 07:46:14 PM »
Ah - misunderstanding! I thought you were referring to Ports&Pins.
Dir pulse width does not apply/matter. Ignore.
Step - well, should not matter, but try setting it to 1 or 2, just for LOLs?
Otherwise - geez, I dunno.

Cheers

Offline PW8697

  • Active Member
  • Posts: 51
    • View Profile
Re: Backlash when enabled, kills everything.
« Reply #14 on: October 30, 2015, 04:17:19 PM »
Its been a few days and finally have the mill running with backlash compensation enabled.  Ended up being the plugin for the interface card was incorrect.  Took four or five tries with Automation Technologies tech support to get one that works.  But got it running today.  I now have to study up and see about running with exact stop or constant velocity and the pros and cons of each. 

All in all the fix for this backlash compensation enabled deal was getting the correct driver.