Hello Guest it is September 21, 2019, 10:40:36 AM

Author Topic: machine not cutting as simulation.  (Read 5353 times)

0 Members and 1 Guest are viewing this topic.

Re: machine not cutting as simulation.
« Reply #20 on: October 10, 2015, 05:39:57 PM »
Hi. Fixxitt. Yes. You are correct. It does move only half the distance. Everything I draw, I have to double the scale on Mach3. I have also used Aspire. Same thing. G code inch works. I've tried using a few post processors. Not sure if I've tried the one you mention. The machine works just fine. Would be nice to have this right though. Regards... Ronnie
Re: machine not cutting as simulation.
« Reply #21 on: October 12, 2015, 10:08:02 AM »
Ronnie,  
its moving half the distance because Mach3 is not configured to your machine correctly.   It has nothing to do with any type of cam/post processor issue.  It is all in mach3.

Go to CONFIG>MOTOR TUNING.  You will be in the X axis motor movement profile. The bottom left corner is the "STEPS PER" box.  This is where you "TELL" mach 3 how many steps it needs to make to move one UNIT.  Be it inches or MM`s.  So if you tell your machine to move 1 inch, and it moves less then one inch, then your STEPS PER is to small.  If it moves more then the steps per is to big.

So right now if your machine is moving half of what it should, double the steps per.  YOU MUST CLICK THE "SAVE AXIS SETTINGS" BUTTON ON EACH AXIS BEFORE MOVING TO THE NEXT ONE.
Here are the steps.  It can be a little tricky if you do not rezero the work coordinates after a motor tuning change.

Get a ruler, place it on the table along the X axis. lower your spindle/tool over an inch mark on the ruler.  Zero the work coordinates for X
Use the MDI line and type G0 x1 and press enter.  See how far it has moved.  You want it to go to the next inch mark
In the MDI line again type x0 and press enter.  This takes you back to the starting point.

Config> Motor tuning> x axis  Adjust the steps per higher or lower by guestimation on have for the x axis moved.
Click the SAVE AXIS SETTINGS BUTTON  
Click Ok to get back to the main mach screen.
STOP!!!!!!!!
LOOK AT THE X AXIS WORK CORDINATES!!!!!!!!  They are no longer set to zero.  The change of the steps per caused them to change.

Zero the work coordinates for the X axis and replete the MDI moves.

Dial it in.  If you forget to rezero the X axis after a change.  Telling it to move to X 1 will give you a funky rotation that could throw you into a mind loop.  

I know it sounds like a crap ton of complicated stuff, but it really is not.
Re: machine not cutting as simulation.
« Reply #22 on: October 13, 2015, 02:50:39 AM »
Thanks fixxitt. Very nice of you to spell it out for me. I am in the middle of a project that I need for the weekend, so I'll wait till the job is finished, and then follow your instructions. I'll let you know how it goes. Thanks again to all who have helped. Regards... Ronnie.
Re: machine not cutting as simulation.
« Reply #23 on: October 13, 2015, 11:01:03 AM »
I dont use the standard mach 3 screenset, so I had forgotten about this until yesterday, but go into the settings screen, very bottom left is AXIS CALIBRATION  "Set Steps per unit" button.  Follow the instructions.  Make sure you can accurately measure movements.
Re: machine not cutting as simulation.
« Reply #24 on: October 13, 2015, 07:24:00 PM »
Thanks Fixxitt. I assume you mean follow the instructions on that page. Had a look at the first step, where it askes how far I want to move the x axis. Is 1 one inch? For instance? I'm just not game to change anything till I've finished cutting my stuff for the weekend. Would be a disaster if I couldn't finish it. I'll have a go when that's done. Regards... Ronnie.
Re: machine not cutting as simulation.
« Reply #25 on: October 14, 2015, 07:36:40 AM »
Ronnie,  the box that asks how far you want to move is the native units.  so if your setup in inches it will be an inches move.  So if you told it you wanted to move 5 inches or 1.  It will use the motor tuning config to move what it "knows to be that value.  make sure you Zero that axis first.   Then you measure how far the machine actually moved and put that in the next box that pops up.  It will calculate the steps per.  So being able to accurately measure the movement is a plus.
Re: machine not cutting as simulation.
« Reply #26 on: October 14, 2015, 06:13:43 PM »
Oh. Ok. That sounds good. I'll give it a go and let you know what happens. Regards... Ronnie.
Re: machine not cutting as simulation.
« Reply #27 on: October 24, 2015, 12:51:16 AM »
Hi. All. Fixxitt. I haven't done that adjustment yet. Still try to get a few things done. Taking longer that expected. Even though my other issue seemed to be solved and was working fine, it's come Back again. Cutting a new small arched v cut profile for model windows and the machine is cutting a few rounded corners here and there. The tick stop cv on angles 89 degrees worked for my other windows. I notice that in the same cv control box next to the above mentioned parameter there is another one.cv tolerance. This is not ticked but has a figure of 180 units. Should this be a different figure? The machine works fine on everything else I do on it. This has got me puzzled. Regards Ronnie.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: machine not cutting as simulation.
« Reply #28 on: October 24, 2015, 07:40:02 AM »
The best way to get rid of rounded corners is to increase the acceleration settings, IF your machines is capable of accelerating faster.
Otherwise, I'd try playing with the CV angle setting, and wouldn't bother with any of the other CV settigns, unless you want to do several hours of careful testing to find out what works best for your machine.

Here's a document that explains what the CV settings do.
http://www.machsupport.com/wp-content/uploads/2013/02/Mach3_CVSettings_v2.pdf
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: machine not cutting as simulation.
« Reply #29 on: October 24, 2015, 08:26:35 AM »
Thanks Gerry. I'll try your suggestion and see how it goes. Its weird though. The fix you gave me last time worked perfectly. This is the same type of drawing as then all done the same way, but now its playing up. Anyway try again. Thank you. Regards... Ronnie.