Hello Guest it is September 20, 2019, 08:47:58 AM

Author Topic: This GCODE make my cnc motor loosing steps  (Read 1187 times)

0 Members and 1 Guest are viewing this topic.

This GCODE make my cnc motor loosing steps
« on: September 11, 2015, 01:28:07 PM »
Hello, I just broke my tool because of a thing I can't understand, the following code make the tool go up very fast (faster than configured in mach3 ? possible) and the motor lose some steps, which is... NOT GOOD !
This is the gcode:

Code: [Select]
G01 X21.3632 Y-0.3265
X21.3582 Y-0.3354 F500.
G02 X21.259 Y-0.48 I-0.8717 J0.4914
X20.9725 Y-0.8026 I-3.6232 J2.9299
X20.8609 Y-0.899 I-1.5468 J1.6772
G03 X20.771 Y-1.026 I0.1912 J-0.2308 F87.743
X20.7588 Y-1.0646 Z-2.5627 I0.3858 J-0.1424 F500.
X20.7506 Y-1.1042 Z-2.1189 I0.3979 J-0.1038
X20.7462 Y-1.1444 Z-1.6751 I0.4062 J-0.0642
X20.7458 Y-1.1849 Z0.1 I0.4106 J-0.024
G01 Z2.5
X38.7506 Y-0.8455
Z5.

I think it happens before the "G01 Z2.5" but not very sure.
Then my first question is, is a program able to make the motor go faster than configured ? (I tried to reduce the motor speed very much and it is slower but too slow for other operations.
Then my second question, when I move using the keyboard is it the fastest speed as configured "motor tuning" ?

Thanks in advance for your help.

Offline mbele

*
  •  58 58
    • View Profile
Re: This GCODE make my cnc motor loosing steps
« Reply #1 on: September 12, 2015, 02:28:10 AM »
Hi,

I think that the answer to your questions may depend on version of mach3 you have installed (bugs).  Generally, mach3 honors motor tuning - you should not be able to jog faster than the motor is tuned(eg using shift key and cursors), but there were versions/configurations where people reported that mach3 jogs faster than tuned (v042.033 IIRC)

From my experience with v042.020: I was tuning servos for lowest possible following error, and there were few gcode samples that looked similar to your code (some shorter XY linear moves and arcs, then Z-axis only move, then longer XY move) where following error was doubled (in XY that I know of) somewhere around Z move. I had to reduce acceleration in motor tuning to get the machine to pass the test.  What I haven't tried, and it may have helped, is inserting a G4 P0 before and/or after Z axis only move.
I've also experienced some problems with feed override above 100% and G1 moves at feed rates close to limit, where machine would try to move faster than tuned, but I'm not sure which version of mach3 I was using at that time, and I learned not to do that anymore :)

I couldn't make much sense from the code you've posted, but the G01 Z2.5 is to be executed at F500, same as helical arcs before that Z move and the linear move after that Z move - does it actually execute faster ?

HTH
Mihael
Re: This GCODE make my cnc motor loosing steps
« Reply #2 on: September 12, 2015, 12:57:21 PM »
I followed your advice and switched from a v042 to a v043, and the problem disappeared, also thank you for your help !