Hello Guest it is October 19, 2019, 01:40:54 AM

Author Topic: emergency stop  (Read 2457 times)

0 Members and 1 Guest are viewing this topic.

emergency stop
« on: August 11, 2015, 10:41:58 PM »
have a Mach3 installation.....along with the standard parallel port I have an addition parallel port with an i/o breakout board. If I set any of the inputs on either board (the second is installed in a separate enclosure with no high voltage around it) to Emergency Stop the machine will run for a few seconds and then trip and indicate an estop condition. Input is wired to a maintained push button. Tried both high and low triggers. Also hard wired the input with similar outcome.

Anyone have a clue? Any help appreciated.

No...its not a wiring or power supply issue.

Thanks, bob  :(

Online Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: emergency stop
« Reply #1 on: August 12, 2015, 11:38:18 AM »
Quote
No...its not a wiring or power supply issue.

Sounds like electrical noise Bob.
I recommend that your inputs wiring should be good quality, twin core, shielded / screened, cable with the shield connected to Earth at the controller end only.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: emergency stop
« Reply #2 on: August 14, 2015, 01:36:44 PM »
thought noise first as the original parallel port is connected to a breakout box controlling the axis's and spindle. Moved estop to the second port which is connected to a different i/o board which uses 24vdc inputs and is located under the table in a separate enclosure (its ~1ft from the pc). I tried both ports and set the input to trigger low with the input tied directly to 24v (both breakout boards use separate supplies) and with the trigger set for high with the input tied to 0v. In all cases Mach3 indicates an estop condition several seconds after we start running. If does not occur if we move any axis or use the spindle in manual. I'm pretty sure its not noise.

Online Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: emergency stop
« Reply #3 on: August 16, 2015, 06:01:08 AM »
Quote
I'm pretty sure its not noise.

Hi Bob,

If your inputs wiring (by this I mean all your inputs to Mach3, not just the E-Stop) are as I described previously then I would be inclined to agree with you.  ;)

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: emergency stop
« Reply #4 on: August 16, 2015, 11:04:31 AM »
thanks......I'm an industrial automation integrator......I doubt its the wiring......needed to know if this was a common issue. Regardless of the type of wire, reversing the trigger from high-low or low-high should have eliminated the issue for one of the wiring conditions. I'm doing some additional testing perhaps that will indicate problem. I'm also reviewing Mach3 for another installation. Hard to recommend since the machine is in someones plant, not in a garage or basement. Can't install any type of controls without guarding and estops, unlike the vast majority of the people using this.

Offline mc

*
  •  381 381
    • View Profile
Re: emergency stop
« Reply #5 on: August 16, 2015, 03:57:46 PM »
I doubt it isn't a wiring problem.

I'd be going over the wiring checked for potential ground loops, especially on the PC wiring side.
Do you have the external enclosure grounded separately grounded?
If you do, I'd guess you've probably got a ground loop between the PC, and enclosure via the parallel cable. Try cutting the shielding of the parallel port cable at one end, and see if things improve.
Re: emergency stop
« Reply #6 on: August 16, 2015, 08:56:45 PM »
I do all sorts of process controls for all different industries........I'm reasonably sure its not groundloops or noise. everything is grounded.....all the power supply commons......enclosures are all mounted to a steel frame and have ground straps.
Re: emergency stop
« Reply #7 on: August 17, 2015, 09:15:47 AM »
Don't know what type of BOB you are using but you might have to add a resistor to the e-stop input to provide a load and 0 volt reference to prevent signal floating. I do allot of PLC and VFD programming and installations and some devices inputs have high impedance that do funny things connected to 24 vdc supplies via switches etc. Its my experience the impedance of most power supplies is pretty high which adds to the problem.  
« Last Edit: August 17, 2015, 09:22:50 AM by geh7552 »
Re: emergency stop
« Reply #8 on: August 17, 2015, 12:48:13 PM »
I was having this issue at one point.  Increasing the debounce interval corrected it (noise...).
I am a mechanical engineer, with much experience in automation.  Things don't always work the way I think they should.  Even if your wiring is perfectly by the book you can be affected by noise.
Joe
Re: emergency stop
« Reply #9 on: August 17, 2015, 05:28:18 PM »
I was unaware the inputs had a debounce setting. Where is it located in the Config?