Author Topic: Galil Error 22 Begin not possible due to Limit Switch  (Read 4879 times)

0 Members and 1 Guest are viewing this topic.

Offline JimDawson

  • Active Member
  • Posts: 12
    • View Profile
    • Dawson Controls LLC
Galil Error 22 Begin not possible due to Limit Switch
« on: August 06, 2015, 05:35:08 PM »
OK, no matter what the configuration is, when I try to run G-code I get the LS error. >:(

It works fine in jog from the keyboard, also I am able to jog from Galil Tools.  My MPG that is wired outside of Mach3 works just fine, Mach3 doesn't even know it's there.

Motors and encoders are all running the same direction, no problem there
Limit switches are wired Active Low, Galil is set to CN0=1
Active Low boxes are checked in the Galil Configuration
Debug file shows a CN 1 is being sent on startup
Again Keyboard Jog works fine

I have tried every possible configuration in the Ports and Pins config, including removing all reference to the limit switches.
I have also tried un-checking the Active Low boxes in the Galil config and tried every possible configuration in Ports and Pins

Again, everything works until I try to run g-code, and it still works after I try to run g-code.

Any ideas? ???

Thanks, Jim
Controls Engineer
Machinist
Machine Design/Build

Offline JimDawson

  • Active Member
  • Posts: 12
    • View Profile
    • Dawson Controls LLC
Re: Galil Error 22 Begin not possible due to Limit Switch
« Reply #1 on: August 06, 2015, 07:51:13 PM »
OK, I figured it out. I'm running a 4080 controller, and had D(W) and E(A) axis enabled in Mach3.  Neither of which have the limit switch inputs wired in.

D axis is reserved for future expansion of a rotary axis.  E axis is the tool changer and is not under Mach3 control.  E axis is operated via DMC code resident on the 4080.

Since the limit switches are set for Active Low, and not being pulled high, it looked like they were tripped.  I disabled the axes in Mach3, and my problem was resolved.
Controls Engineer
Machinist
Machine Design/Build