Hello Guest it is September 21, 2023, 08:56:17 AM

Author Topic: Used EStop and now steppers aren't working  (Read 5022 times)

0 Members and 1 Guest are viewing this topic.

Re: Used EStop and now steppers aren't working
« Reply #10 on: July 19, 2015, 08:20:10 PM »
I've never used a 540, but it looks like if you are ignoring the Charge Pump, and have the Enable terminal to ground (jumper or button) it should come out of fault regardless of what Mach is doing.
Here is one note from the manual too:

"NOTE: If you have a motor miswired, the G540 will not exit FAULT mode.
Connecting the motors one at a time will help identifying which motor in particular is
miswired if it enters FAULT mode at this step."

You might make sure all of the motor connections are good.

Re: Used EStop and now steppers aren't working
« Reply #11 on: July 19, 2015, 08:55:45 PM »
Thanks Russ,
I'll go double check all of the motor connections to see if maybe I knocked something loose.

Thank you,
Re: Used EStop and now steppers aren't working
« Reply #12 on: July 21, 2015, 09:56:10 PM »
I just wanted to update you all to let you know what's going on.
Not that I have very solid information to update with, but here's what I do have:

I installed the xml profiles from cncrouterparts and tried running from that profile.
This time my estop would NOT reset and it kept saying external Estop requested.
Also every time I hit the reset button, for that very split second that I hit the reset, it would turn on at least on stepper.
I tap the reset again and it turns on a stepper at that very moment.
I probably did it 10 or more times just because I was happy that it was at least doing something.
Then I tried the old profile that I had and it was working again.
I either changed something or something got changed on its own, but now my Y axis steppers are moving in opposite directions.
I'm going to try and figure this one out on my own, because I know I've dealt with this several years ago when I first set this all up.

I just wish I knew how to get around in this Mach3 software better. I feel like one little thing goes wrong and I have no clue what to do.
I think if I HAD to use it more, I would know how to use it, but I pretty much set it up years ago and it has worked flawlessly until just the other day so now that i need to know how to do something, I am clueless.

I appreciate all of you for trying to help me. I know it can be difficult trying to help someone from hundreds or thousands of miles away and even more difficult when you're talking with someone as stupid as myself regarding the subject.

I'm going to make sure I make backup instructions of my settings once I get this all figured out so that next time I will at least have a reference to go back to what worked before.

Thank you all again. I appreciate the attempts to try and help out someone who probably doesn't know 1/100th as much as any of you knew back when you knew 1/100th what you know now.

It feels good to be close to being back up and running again.

Best Regards,
Re: Used EStop and now steppers aren't working
« Reply #13 on: July 29, 2015, 06:51:50 PM »
I had similar problem- it was indeed a confusing problem with the Charge Pump.  IIRC the problem is, the GeckoDrive trips the FAULT pin if the Charge Pump signal is not on.  Mach3 was turning off the Charge Pump in the disabled "Reset" state... which it goes into if the FAULT pin goes active.   

Sometimes it will power up into a working state and sometimes not, but if the E-Stop was triggered, it couldn't be fixed.  Mach3 will see the FAULT condition and refuse to come out of RESET.  The G540 will keep that FAULT signal active indefinitely because there's no Charge Pump signal.