Hello Guest it is May 14, 2021, 09:09:19 AM

Author Topic: No Script Engine Found for ...  (Read 7461 times)

0 Members and 1 Guest are viewing this topic.

Offline Osker

*
  •  41 41
    • View Profile
Re: No Script Engine Found for ...
« Reply #30 on: May 17, 2018, 07:37:29 PM »
I am getting the "No Script Engine Found" error.  From the operator tab I select the edit scripts option.  It takes me to the profile's macro folder.  Since this is the first script in the new profile's folder, the folder is empty and the editor does not open.  That prevents me from being able to create a new script. My solution was to copy a script from the Mach4Mill profile into the new profile, expecting the script editor to open; allowing me to create a new script.  Instead, I get the "No Script Engine Found" error and no opportunity to create a new script.


Any suggestions for how to properly create a new script would be appreciated.

Regards,

Dan

Re: No Script Engine Found for ...
« Reply #31 on: May 17, 2018, 07:45:31 PM »
Hi,
just confirm that the Lua plugin is enabled. In early builds Configure/Mach/Plugins in the most recent
Configure/Control/Plugins.

Craig
My wife left with my best friend...
     and I miss him!

Offline Osker

*
  •  41 41
    • View Profile
Re: No Script Engine Found for ...
« Reply #32 on: May 18, 2018, 11:03:03 AM »
Craig,

You nailed it!  The Lua plugin is now enabled and working. 

Thanks,

Dan
Re: No Script Engine Found for ...
« Reply #33 on: May 18, 2018, 06:42:03 PM »
Hi Dan,
just as a matter of interest what build of Mach are you running?

I downloaded 3756 which was a development version at the  time but it has the new Zero Brane editor and is a very good step up from the previous Lua editor.
Amongst other things you can launch it without actually having any macros or whatever for it to act on. It has a navigation panel so you can scan around within Machs
directory to find what you want. This makes it possible to have say a macro that you are working on to go in your own profile but have an example macro from
the Examples folder and screen scripts, ie not macros at all, ALL open and available on the desktop as separate tabs, each editable and can be run in debug mode
with much increased facilities compared to previously.

Byranna has just released a video on it.

Craig
My wife left with my best friend...
     and I miss him!

Offline Osker

*
  •  41 41
    • View Profile
Re: No Script Engine Found for ...
« Reply #34 on: May 18, 2018, 07:11:55 PM »
Craig,

I am running MACH4 Hobby Ver. 4.2.0.3481 Build 3481.  I just downloaded Ver 4.2.0.3804 and will install it tomorrow.  Thanks for the heads up.  Since I am still transitioning from MACH3, I had rather be learning the most current version.

Today's big accomplishment was scripting a very simple M6 for manual tool changing.  DazTheGas's videos were very helpful, although I only need to pause and display a "Change Tool and Press Cycle Start" message.


Dan

Dan
Re: No Script Engine Found for ...
« Reply #35 on: May 18, 2018, 07:21:55 PM »
Hi Dan,
when you update to the latest build you should have BOTH an individually named profile AND screenset. This is a post I made a wee
while ago that explains why:

http://www.machsupport.com/forum/index.php/topic,37337.msg255420.html#msg255420

Craig
My wife left with my best friend...
     and I miss him!

Offline Osker

*
  •  41 41
    • View Profile
Re: No Script Engine Found for ...
« Reply #36 on: May 18, 2018, 07:29:23 PM »
Craig,
Thanks for the heads up   I read your explanation and the reasons are logical.  I would have been caught by the lack of a unique Screenset.  Will do that tomorrow.  You are rapidly elevating your status from Mach4 Guru, to Mach4 Wizard :>)


Dan