Hello Guest it is March 23, 2023, 01:23:03 AM

Author Topic: optimization.txt  (Read 6570 times)

0 Members and 1 Guest are viewing this topic.

« on: July 27, 2008, 08:28:15 AM »
Hi to all
I have installed mach 3, did the start-up as required, then ran the driver test, all is well but the spikes that is showing is between 0 and 60 micro seconds, the line maintain at 38 micro seconds, what to do to have a nice flat line with small spikes

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: optimization.txt
« Reply #1 on: July 28, 2008, 08:42:20 AM »
Have you tried running your machine, it may work ok if its just occasional spikes.
Have you done the optimisation steps?
If you have then there may not be much you can do apart from making sure you dont have any software that is interupting the Mach pulse engine, Apples QuickTime is notorious for doing it.
 If you are using a Laptop make sure all of the power saving options are turned off.
If a desktop with onboard graphics then you could try putting a graphics card in and using that.
Another option would be to get a SmoothStepper, it generates the pulse externally so is not hampered by any software  interuptions.

Re: optimization.txt
« Reply #2 on: July 30, 2008, 09:38:31 AM »
Thank you for the information, i will follow the steps as suggested, enjoy the day