Hello Guest it is October 20, 2019, 08:52:27 PM

Author Topic: Need help - Jerky movement with large files - CPU usage maxes out  (Read 2276 times)

0 Members and 1 Guest are viewing this topic.

Hi all!
  I'm having some difficulty trying to do some 3D cutting with very small line segments.  The g code that was produced is just shy of 100K lines.  I can start the program, and it runs fine until it hits about the 20K line mark, then I start getting very jerky movement on all 3 axis.  I also notice that when I start getting the jerky movement, mach 3 is using a full 50% of the CPU (dual core machine), and when it's running fine, it only uses 28-45% of the CPU.

Just to test it out, I took a segment of code out of the middle, where I was getting very jerky movement (about the 39K-40K), and saved this as a new file that was only about 1k lines long.  The machine runs fine with this file, and CPU usage is about 30%.

I've tried disabling the tool path preview to save system resources, but this didn't really help at all.  I'm not sure what else to do, except manually edit the G-code into multiple files, which is something I'd really like to not have to do.

computer specs:
HP DC5700 small form factor
Windows 7 32 bit
Intel Pentium 4 (2 CPU's) 3.00GHz
1Gig ram

Is my computer just not up to par?  Any suggestions on how to get a little more performance out of it?

thanks in advance for any suggestions, they are truly appreciated!

-Brian

P.S. G-code file is attached for reference



Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #1 on: April 25, 2015, 08:52:15 PM »
What is the look ahead set to ?

(;-) TP
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #2 on: April 25, 2015, 08:58:30 PM »
Look ahead was set to 20, changed it to 200, no difference.

Thanks

Brian

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #3 on: April 25, 2015, 09:09:50 PM »
Turn off the toolpath display and it should run fine. This is a known issue with large files.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #4 on: April 25, 2015, 09:11:39 PM »
Unfortunately, I tried that and it did not work.

Any other suggestions?

Thanks

Brian

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #5 on: April 25, 2015, 09:17:02 PM »
Does your PC have a separate video card?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #6 on: April 25, 2015, 09:55:50 PM »
It does not, it's a pretty basic machine, I only have Gail tools and mach 3 installed in it.

Thanks

Brian

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #7 on: April 25, 2015, 10:00:29 PM »
Are you using the parallel port?
A separate video card is a requirement for running Mach3 with the parallel port.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #8 on: April 25, 2015, 10:21:24 PM »
I'm using Ethernet.  The controller is a Gail dmc2183.  I might have an extra video card to try in the machine, I'll try that one I get home to see if it helps.  I appreciate the advice.

Brian

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Need help - Jerky movement with large files - CPU usage maxes out
« Reply #9 on: April 25, 2015, 10:33:11 PM »
GUYS we are going to have to start asking what controller they are running first thing. Else we just chase our tales over and over again.

You are probably having Galil buffer problems

Just a thought, (;-)