Hello Guest it is November 18, 2019, 04:01:35 AM

Author Topic: need some help  (Read 1204 times)

0 Members and 1 Guest are viewing this topic.

Offline dude1

*
  •  1,253 1,253
    • View Profile
need some help
« on: April 21, 2015, 11:42:11 PM »
I have run into a problem where I have connected up a laptop to the ESS tried running it in M4 and M3 I get the same problem the machines Z axis is out by the same amount after running 1000 Z moves in M4 its out by -.75 mm after each 1000 z moves.
and in M3 its out by -1.45 mm. its the same on each run, I have changed settings slowed things down still get same out by or worse change back to where its -.75 out in M4 and -1.45 in M3. I can`t for the life of me find what the problem is, M4 and M3 seem to be running fine as well as the ESS and the MB06 V2 bob its connected to they are connected to G213V gecko drivers what have the correct current limiting resistors on them, they are tuned by ear.
would using a oscilloscope be a better way of tuning them if so what type of oscilloscope would be the correct to use I know next to nothing about them or how to use them attached is the M3 xml

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: need some help
« Reply #1 on: April 22, 2015, 11:52:40 AM »
Could be you have the drive switch state backwards to what is required (active high/ active low). Some drives will loose steps if that is backwards . Try varing the pulse width  if 1ms then try 5ms or 15ms.

Try dropping the accel and velocity values by 50% then retest.

Just a thought, (;-) TP

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: need some help
« Reply #2 on: April 22, 2015, 01:24:17 PM »
Also assuming your Z moves are back and forth, some drives will loose the first step after a change of direction - can't remember why - Terry will know.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: need some help
« Reply #3 on: April 22, 2015, 03:27:07 PM »
I was think of changing everything to active high

drooping the accel and velocity works at 500mm/sec and 50 acc it comes right its a big machine 1200n steppers

yes z moves are back and forward

I will change everything over to active high on Friday.

thanks for suggestions terry / sterling