Hello Guest it is May 16, 2022, 08:26:23 AM

Author Topic: hickup at 12 and 6 oclock  (Read 7286 times)

0 Members and 1 Guest are viewing this topic.

Offline zarzul

  •  231 231
  • Wyoming, USA
    • View Profile
Re: hickup at 12 and 6 oclock
« Reply #10 on: April 20, 2007, 09:56:38 AM »
I had the same problem with backlash compensation enabled on the y axis, it is doing its little shift for the backlash at those two points.

Offline Chip

  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: hickup at 12 and 6 oclock
« Reply #11 on: April 20, 2007, 04:25:16 PM »
Hi, Graham

I loaded your Settings and Code, steps 1280, vel. 1800, acc. 150, To achieve vel of 1800, You need kernel speed of 45K, Re-boot Reguired after changing.

I dont see any slowdown at 6 pos, But the 12 pos has a pause, It's Caused by the Gcode line change.

Mach ramps down using your Acc. setting even in CV mode.   

There is a relationship between Steps, Vel, and Acc. settings, Hear is an example.

I have a Sherline mill with a 4th Axis, 10 micro steep controls.
X, Y, Z settings, S 7500, V 40, A 18
4th Axis, S 400.2, V 2500, A 500

Give this a try, set your Kernel speed to 45K re-boot if needed, S 1280, V 1800, A 350 - 450.

The way I setup from scratch is set slow Vel. Acc., Calibrate the Steps required to move 1 unit, Inch/MM.
Set the velocity up to a speed that you trip/lose steps or it's just too scary!!, Then back it off some.
Set the Acceleration up to a speed you trip/lose steps then back it off some.

This will give you a Max speed for your G00 Moves, F- Setting for G01, G02 & G03.

Note: You need to do some X, Y, Blended moves to determin whether you lose steps with multi axis moves.
You may need to reduce the Max Vel. and Acc. some, If your start / return position is off.

G00 X0 Y0
G00 X10 Y10 ( adjust to distance to get max blended Vel. to display)
G00 X0 Y0

Additionally you may need to reduce your Acc., If it's to fast for the material your cutting.

It's all a balancing act any way.

Hope this Helps, Chip