Hello Guest it is May 06, 2021, 06:27:52 PM

Author Topic: Mach 4 Tool Auto Zero  (Read 15440 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 4 Tool Auto Zero
« Reply #10 on: March 26, 2015, 05:48:19 PM »
I was spending some much needed time with Joe Crumley in Norman, OK! learning how to properly use my machine!
Re: Mach 4 Tool Auto Zero
« Reply #11 on: March 27, 2015, 03:30:15 AM »
the G-Code Function works but when it gets to the G31 Command Mach 4 says that "probing is not yet supported by the motion Controller"
This is because the probing function may not be set up right on my end, or the firmware actually does not support the probing function.

I am using the PMDX-422 SmartBOB for your information.

Thanks for any and all replies.

V/R
Mike
Re: Mach 4 Tool Auto Zero
« Reply #12 on: March 27, 2015, 03:31:32 AM »
I went to the plugins section for the 422 and found only 2 options for probing.
1. wildhorse low pull up
2. wildhourse high pullup (strong pull up)
Re: Mach 4 Tool Auto Zero
« Reply #13 on: March 27, 2015, 04:58:04 AM »
As of 27 March 2015, the plugin and firmware for the PMDX SmartBOB-USB boards
does not support probing yet. This applies to both tool length probing and digitizing
of coordinates. Our software for probing support is mostly developed and we expect
to release it next week. New plugins and firmware can be downloaded from our
web site. When this release occurs, it will be announced here:

http://www.pmdx.com/PMDX-Forums/index.php?board=2.0

You can request automatic notification of announcements by following the instructions
here:

http://www.pmdx.com/PMDX-Forums/index.php?topic=55.0

The options that you see in the PMDX-SmartBOB-USB plugin configuration dialogs
are for controlling the electrical characteristics of the signal input used for pin 15 on
the SmartBOB-USB. This one pin has special properties for accommodating the behavior
of Wildhorse brand of digitizing probes and similar ones which contain an LED connected
across the electrical contacts inside the probe.
« Last Edit: March 27, 2015, 05:05:48 AM by Steve Stallings »
Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.
Re: Mach 4 Tool Auto Zero
« Reply #14 on: March 28, 2015, 02:30:17 AM »
So I decided just to manually touch off the plate to the tool, and on the Machine Diagnostics Tab the probe light turns on when the circuit is completed. I believe that it is just the motion controller awaiting the aforementioned update to allow the configuration of the auto-zero.

Thanks again Steve!
V/R
Mike

Offline Pedio

*
  •  200 200
    • View Profile
Re: Mach 4 Tool Auto Zero
« Reply #15 on: July 28, 2015, 05:08:49 PM »
Did you guys get this to work? I believe that the smartBob now has probing working. I can get the LEDs to change when my touch plate is touched to the bit.

Also, not sure how to use G-code in the Lua interface. Do I just enter it where the script goes? Will this reset my Z=0 for the machine or only set a difference for the one run of the current file? Anyone have a script that works. This would make my life compete (until I hit the next challenge).   ;D

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach 4 Tool Auto Zero
« Reply #16 on: July 28, 2015, 06:32:10 PM »
just go here and get the probing screen set http://machremote.dyndns.org:8080/

Offline Pedio

*
  •  200 200
    • View Profile
Re: Mach 4 Tool Auto Zero
« Reply #17 on: July 28, 2015, 09:17:50 PM »
Ok - downloaded it. How do I make it work?

Offline Pedio

*
  •  200 200
    • View Profile
Re: Mach 4 Tool Auto Zero
« Reply #19 on: July 29, 2015, 01:49:57 PM »
I saw the instructions and was able to install the screenset successfully; however, I am not sure how to activate an Auto tool Zero session using this screenset. The Screen set I was using supported G31 via SmartBob. I am able to type a G31 command into the MDI and have the Z axis move / stop moving when I touch the plate to the bit. What I expected and did not see in the Probe screen set was a script behind the "Auto Tool Zero" button.

Thoughts?