Hello Guest it is June 08, 2023, 06:01:40 PM

Author Topic: Y carriage rolling back and forth in terrible, KLUNKY, struggling manner!  (Read 1896 times)

0 Members and 1 Guest are viewing this topic.

I'm moving this machine the first few times... and am using Mach3. I starting cutting some wood, v-carving-type stuff. It seemed to be going to slowly so I stopped. Then I sped up the 3 axes' speeds. When I went to restart it I may have accidentally inadvertently had it start from an unfortunate spot.

It did a clunky thing then began to bury its router bit in the throw-away mdf tabletop. I hit the emergency stop. But then, when I tried to restart it, the Y axis was moving in this really clunky fashion. I thought maybe one of its stepper motors quit working so I disconnected them to see if they'd spin properly when I told it to move in the Y axis. They both spun fine.

Then I thought maybe it was because the rack and pinion was dusty/greasy. I carefully cleaned. Maybe it was slightly better, but still very clunky, not smoothly gliding back and forth on the Y axis. So then I thought maybe the two Y axis cogwheels were out of sync with each other... that maybe the Y carriage was binding. I dropped one Y-axis cogwheel, then rolled the carriage back and forth a time or two. This was my first & only time to do this. But it seemed to roll fine. I re-attached the Y-axis cog wheel then told it to move in the Y axis with a Mach3 command and it still was struggling to roll in a terribly clunky, miserable fashion as I hit the arrow keys on my keyboard trying to make it roll back and forth. Any ideas?

Here's a video of the Y carriage rolling back and forth in terrible, KLUNKY, struggling manner:

Offline RonC

  •  32 32
    • View Profile
Hi Mihaly,
Sounds to me as if your motors are stalling, try reducing motor speed, and or, accel in motor tuning, reduce by say 50% give it a try, if it works OK try increasing speed gradually until it stalls again and then reduce a couple of percent until they run reliably.
Remember reliability is the goal not top speed!!
Good Luck
YESS!! It worked! Exactly. Thanks a lot.