Hello Guest it is July 14, 2020, 06:41:03 PM

Author Topic: Unsolicited Pauses Between G00 and G01 Commands?  (Read 10686 times)

0 Members and 1 Guest are viewing this topic.

Offline Graham Waterworth

*
  • *
  •  2,104 2,104
  • Yorkshire Dales, England
    • View Profile
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #10 on: April 11, 2007, 06:49:38 PM »
Hi Ryan,

It looks to me that your cam system is wasting more time than the delays by putting all the unwanted Z moves in, get a better post or a better cam system and you will save time and money.

Graham.
Without engineers the world stops

Hood

*
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #11 on: April 11, 2007, 07:08:46 PM »
OK so its your code thats mopving to the "safe Z" so thats not a problem. Will test out in the morning on my mill and see if I get delays but I am almost certain I dont. Its late here so I am going to grab some sleep.
Hood
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #12 on: April 12, 2007, 11:01:42 AM »
Yes graham that's absolutely true. Maybe it's time I looked into that. Especially if this 'delay' thing doesn't get sorted out.

BTW hood, I really like your touch screen layout. Just discovering the whole customizable screen area of mach3... it's really, really satisfying!

-Ryan.
« Last Edit: April 12, 2007, 11:04:15 AM by ryanosman »
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #13 on: April 12, 2007, 12:04:32 PM »
Ryan,
We must stop after we do a rapid. and I don't think that the pause is as great as 1/3 of a sec... if it was that long I would be bitching about it! There are many problems that will happen if we start doing CV with the rapid moves :(

I think the pause is not as long with the G100... (I could be wrong)
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Hood

*
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #14 on: April 12, 2007, 12:10:29 PM »
Tested it out on my mill today and I dont even notice a pause, maybe my brain is just that slow that I dont pick it up ;)
Hood
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #15 on: April 12, 2007, 03:10:17 PM »
Okay I did some time tests. I have my machine set to 80 inches per minute, accell/decelling at 20 inches/sec/sec. When doing consecutive 1 inch G1 moves, my machine takes .73secs each 1inch move. That's the fastest condition. When I do consecutive G0 moves (with the stop between, but no pause). the machine takes .77 seconds each, so like I said, no cv on rapids is not a big deal. When I alternate G0 & G1, the machine takes 1.00 seconds per move. That means the delay is about 1/4 second.

But if it remains a mystery, I can just look for a smarter dxf->gcode converter. Lazycam doesn't seem too bad...?
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #16 on: April 12, 2007, 03:59:28 PM »
Are you running a printer port?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #17 on: April 12, 2007, 04:30:13 PM »
yep. printer port -> 3 custom programmed micros -> 12 high current transistors (... and a whole bunch more junk...) -> 3 stepper motors.
« Last Edit: April 12, 2007, 06:16:37 PM by ryanosman »
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #18 on: April 12, 2007, 04:58:59 PM »
Could you please post an example file and we will have Hood test it on his setup

Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Unsolicited Pauses Between G00 and G01 Commands?
« Reply #19 on: April 12, 2007, 06:15:01 PM »
This should do a quick & easy demonstration of what I'm seeing.

F100
g00 x0y0z0
(accel decelled moves:)
g0 x1
x2
x3
x4
x5
(one fluid movement:)
g1 x4
x3
x2
x1
x0
(now with pauses:)
g0 x1
g1 x2
g0 x3
g1 x4
g0 x5
« Last Edit: April 12, 2007, 06:18:00 PM by ryanosman »