Hello Guest it is July 08, 2020, 01:40:49 AM

Author Topic: Homing Switches (2 of 4) won't back off once touching  (Read 3337 times)

0 Members and 1 Guest are viewing this topic.

Offline Vogavt

*
  •  258 258
    • View Profile
Homing Switches (2 of 4) won't back off once touching
« on: February 02, 2015, 03:34:27 PM »
Mysterious issue. Was working fine before. I am using version R3.043.66.

When I home my mill's X & Y axes, everything is fine but when I home the Z or the A, it just stick's and I get a notification that the soft limits have been reached and it aborts the homing routine.

Tried a reinstall of Mach3 but not any better. I haven't uninstalled and reinstalled yet, just tried to overwrite the original.

I do have the configuration set to auto-zero.

I went back a week to use an older xml file but that didn't work either.

Only thing I've done is change out a USB hub to a 10-port model, but don't see where that would impact anything.

Maybe it's just so obvious I'm overlooking it but I can't seem to figure it out.

I really don't want to do a fresh install unless it's necessary.
« Last Edit: February 02, 2015, 03:44:18 PM by Vogavt »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #1 on: February 02, 2015, 03:37:55 PM »
Sounds like you have the soft limits configured such that to get to the home switches Mach would have to go past the soft limits.
Hood

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #2 on: February 02, 2015, 03:47:53 PM »
May be. I have had to manually zero in work coordinates to get them to work. Going to the shop to look at that settings tab.
Don't know what would have made them change though as I haven't been in there in the software in a while.

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #3 on: February 03, 2015, 10:18:27 AM »
Okay, everything looked alright to me but it still doesn't work.

I removed the cheap 10-port hub due to it constantly dropping the peripherals and then reconnecting within a couple of seconds. Was just trying to clean up the wiring a little.

So...

I made screenshots of each dialog box that appears from the drop down menus within Mach3 and saved the images in a folder on the desktop.

I backed up the programs salient files (special macros, license, etc.) and did a complete uninstall of Mach3 including deleting the Mach3 Folder and rebooted.

I then re-installed and started the xml from scratch using the information within the screenshots.

Still no dice.

Vanilla Mach3, no Mach3 2010, no Simple Mach, no Big-Tex.... nothing but a fresh clean install.

X & Y are still finding Home and backing off, but the Z & A are just as before.

Now here's what's weird, if i change the Z min in the homing and limits settings I can 'sometimes" get it to work, "but" if I ever try to home the A-axis (which always fails), the Z won't work again.

These are all on the same wiring (in series) so I don't think it's a strange noise issue.

It has to be some incorrect number (negative or positive) that I'm missing in my Homing & Limits settings.

Could someone take a look at my xml?

Oh, one other thing... on the diagnostics tab I see multiple pins showing their green LED lit. I don't recall that before. Could be, though. Wouldn't you know that's the one snapshot that I failed to capture? Dang!!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #4 on: February 03, 2015, 04:58:47 PM »
Your A Axis seems a bit strange, it is set as a rotational axis in General Config but you have soft limits as 0 and 0.5, that doesnt seem right.
Hood

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #5 on: February 03, 2015, 07:09:11 PM »
Thanks for the response Hood!

I'm just about to give up on this thing. I've been staring at it all day. Yeah, I changed the 0 to 360 & 3600 for the A-Max. I'm clueless as to what it should be. I've also changed every parameter under the A-axis in General Config but "only" because one time it worked for the A-axis and also seemed to have fixed the Z as well. I thought to myself could it really be that simple. Nope! I tried it again and it failed!

I've changed the homing limits and software limits to negative numbers, changed the homing to negative direction in A-axis. Still both the Z & A run up to the triggering of the limit switch and just stop.  They're actually zeroing the number now (which they weren't even doing that before) just I have to manually move them each off their trigger.

Oddly while using the Mach3 2010 screenset and telling the machine to go to the Park position (X4.875, Y1.875 & Z-1.000 on my machine), the spindle traveled up to safe Z of 0.000, triggered the homing switch, then the X & Y moved anyway, then the spindle traveled back down to -1.00!

It appeared to hold the number somewhere and yet allow the other two axes to move and then move off the trigger automatically down to where it was supposed to be.  Did the parking routine again and it failed!

I'm now thinking I may need to reformat the hard disk and seriously start from scratch. Pretty drastic but I'm at a loss.
I keep thinking it has to be something simple, but it's all too flaky with it working then immediately not work.
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #6 on: February 04, 2015, 01:50:00 PM »
in general config raise the debounce interval to 3000, see if that cures it. if you're already at that value go up a bit more.

Offline Vogavt

*
  •  258 258
    • View Profile
(No subject)
« Reply #7 on: February 04, 2015, 01:53:41 PM »
I'll give that a go but seems odd that it would work on only two switches in the same loop as the other two.

Thanks

Offline Vogavt

*
  •  258 258
    • View Profile
(No subject)
« Reply #8 on: February 04, 2015, 01:59:54 PM »
WE HAVE A WINNER!!!

Yeah...I'm shouting!!

 Thank you so much!

I changed it back to 5 and it balked again! Set it to 3000 and am leaving it alone!
Re: Homing Switches (2 of 4) won't back off once touching
« Reply #9 on: February 05, 2015, 08:24:59 PM »
you can lower it but i find lower than 2000 and you get false triggers, cnc machines are noisy things.