Hello Guest it is June 20, 2019, 02:14:30 PM

Author Topic: I say inches mach3 cuts in mm  (Read 3028 times)

0 Members and 1 Guest are viewing this topic.

I say inches mach3 cuts in mm
« on: February 02, 2015, 11:59:09 AM »
I have made several attempts cutting a simple tool path but when my dimension is 5 inches my router cuts 5 millimeters...
 I am using Vectric cut2d to draw and save toolpath. It gives me four options to save for mach3, 2 in inches 2 in mm. All four are ".TXT" files..  have tried all for and each time my finished cut are a tiny version of my drawing. I draw in inches format and my native units in mach 3 are inches. I tried drawing a simple 5 inch square and my machine cuts a 5 mm square. if anyone has any ideas or suggestions I would be tremendously grateful..   
 thank you

Offline BR549

*
  •  6,873 6,873
    • View Profile
Re: I say inches mach3 cuts in mm
« Reply #1 on: February 02, 2015, 12:12:08 PM »
Look up in the MODE line and see IF you see a G21.

(;-) TP
Re: I say inches mach3 cuts in mm
« Reply #2 on: February 02, 2015, 12:22:48 PM »
I'm not sure if I'm looking in the right place but I don't see G21 anywhere in my G code. I have noticed however that when I use my keyboard to jog my X & Y coordinates are counting in millimeters. For instance from 0 if I jog right until my x-coordinate is 5, it has only moved 5 millimeters not 5 inches...  could this be part of my problem perhaps?

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: I say inches mach3 cuts in mm
« Reply #3 on: February 02, 2015, 03:39:23 PM »
Sounds like you have your machine set up in metric units.
Hood
Re: I say inches mach3 cuts in mm
« Reply #4 on: February 02, 2015, 04:10:50 PM »
Thank you both for your suggestions ,it does appear to be set up in millimeters, I've tried to change native units by going in to configure menu but it still doesn't help. I set it to inches on install, its in inches now, and my motor tuning velocity and acceleration are measured in inches too. Everything is very very small. Even the test G codes in my mach3 file cut to about the size of a dime.  I don't mind leaving it set up in millimeters and using my drawing and CAM software in millimeters as well but that doesn't seem to help either. I tried drawing in millimeter mode and it still comes out extremely small. I've been at this all weekend and all day just trying to fix this one issue. I spent so much time getting my drawings ready to cut and now it seems to be cutting everything perfectly well,  just small. I'm running out of things to try short of reinstalling mach3. I just don't think it's an install issue though. My axis values are still measuring in millimeters too. When I jog my X Y orZ axis to a value of 3.000 it has moved a distance of 3 millimeters rather than inches but everything else says it's set up in inches. Nothing I try seems to change this.

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: I say inches mach3 cuts in mm
« Reply #5 on: February 02, 2015, 04:39:17 PM »
Ok simply changing the  Native Units will not work, you also need to change the motor tuning values and save them.
If it was accurate in Metric then you have to multiply the steps per unit by 25.4 and divide the Velocity and Acceleration by 25.4. Remeber to save each axis as you go, restart Mach and hopefully you will be set.
Hood