Hello Guest it is September 19, 2020, 06:26:11 PM

Author Topic: g code does not work with characters  (Read 1976 times)

0 Members and 2 Guests are viewing this topic.

g code does not work with characters
« on: October 09, 2016, 05:49:28 AM »
Hi
I have produced a g code program using CamBam. It is to engrave the letter "J". The program works OK on a G code viewer but not on Mach3. It just draws many circles and nothing that looks like the letter "J"   As I am a Newbie I am not sure where I should look for the problem. Any advice would be appreciated. I have included the program.
Regards
JimKal

Offline Tweakie.CNC

*
  • *
  •  8,447 8,447
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: g code does not work with characters
« Reply #1 on: October 09, 2016, 06:29:07 AM »
Hi JimKal,

You need to go into Config. / General Config. and change the IJ Mode.

If you then Regen. Toolpath the display will be correct and the code should run just fine.

Ideally your Gcode should contain the G90.1 or G91.1 (as appropriate) and this is perhaps a failing of your CamBam post processor.

Tweakie.
KEEP SAFE !
Re: g code does not work with characters
« Reply #2 on: October 09, 2016, 08:50:57 PM »
Thanks Tweaky
Your info fixed the problem

JimKal
Re: g code does not work with characters
« Reply #3 on: October 10, 2016, 12:10:18 AM »
Hi
I have made a program to engrave a string of characters (11) inside a rectangular box. On my desktop computer it displays ok on the copy of Mach3. It also displays correct on a gurber viewer. On my laptop which drives my router, Mach3 displays half the text and none of the rectangular border. When I run the program it gets down to a line which appears to have no error and then drops out.
The Mach3 versions are the same as is the Windows version. I have checked all the settings in both Mach3 programs and they are the same. (except motor and input settings)  I note that the desktop computer has 7.73 G of useable ram and the laptop has 3.89 G.  I wonder if this has anything to do with the problem.
Any suggestions?

Regards
JimKal

Offline Tweakie.CNC

*
  • *
  •  8,447 8,447
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: g code does not work with characters
« Reply #4 on: October 10, 2016, 02:01:48 AM »
if you are not using an "external motion controller" then laptops are not supported so that could be the problem.
Alternately, have you transferred your Mach3 license file to the laptop computer ? if not then your Gcode could be ending at the 500 line limit of the Demo version.

Tweakie.
KEEP SAFE !