Hello Guest it is July 14, 2020, 08:04:05 PM

Author Topic: servo drive connection  (Read 10804 times)

0 Members and 1 Guest are viewing this topic.

Offline fdos

*
  •  326 326
    • View Profile
Re: servo drive connection
« Reply #10 on: April 09, 2007, 12:53:05 PM »
Brian

Ah right it's a flatbed machine,  I have two boxford TCL lathes here, they are slantbeds.

Before you rush off buying new drives, check what your bus voltage is going to the original drives.  Although those motors are rated at 150v it's quite likely they are running at a lower voltage.   Both the drives I mentioned have a max volatge of 80v DC.

The other drives in this range with step/dir inputs are the Rutex drives, but it seems some have had reliability issues with them, and support can be flakey!

It maybe that you will need to look into the psu's you have on the machine to ensure you stay within spec.

Was that machine equipped with a NEE control originally?

Wayne.....

Hood

*
Re: servo drive connection
« Reply #11 on: April 09, 2007, 01:04:28 PM »
Brian just replied to your PM but see Wayne has given you some good info. BTW forgot to say in my PM I am in Carnoustie and workshops in Arbroath.
Hood
Re: servo drive connection
« Reply #12 on: April 09, 2007, 01:34:42 PM »
Wayne,
the drives work fine its the control thats a gonner which is an ANC www.adolph-numerical.co.uk
 and the large spindle motor SSD drive.I emailed Norwin and awaiting reply.
Brian

Offline fdos

*
  •  326 326
    • View Profile
Re: servo drive connection
« Reply #13 on: April 09, 2007, 07:06:22 PM »
Brian

Adolph, what a name for a CNC control!

Whats up with the original control?   Just womdering whether it might better to repair that if it's a simple fault.

Your drives may be OK, but not being step/dir input drives makes life difficult unless you want to fork out $1000+ on a Galil card!  Even then I'm not sure yet how well mach is integrated with the Galil's.

The skyco cards I mentioned earlier take step/dir and convert to +-10v velocity command, but If I recall correctly the drives should be running on Torque mode, what differnce it makes over veloicity mode with the skyco I'm not sure.

The final decision is of course down to you, and you have quite a few options.   Each have their issues.

With the Gecko's or any other DC Brushed drive with step/dir you would probably be up and running quicker.  But you will have to ensure the DC Bus voltage in your lathe is 80v or less.

You should probably also get yourself a breakout board to inteface your parallel port to the machine the CNC4PC type seems to be the best value for money these days.

There are likely things you can resuse from the old control. like the MPG (Jog encoder) if ones fitted.

It's likely your machine also has a spindle encoder, this is not usable for screwcutting with mach via the parallel port.  If you wish to have screwcutting and use the parallel port then a simple index signal is required.   There are other devices that MAY allow spindle syncing via encoder sooner or later (G100 from Gecko)



Wayne.....

Re: servo drive connection
« Reply #14 on: April 10, 2007, 06:26:51 AM »
Wayne ,
I emailed Norwin and got a quick reply here it is:-

The drive requires an analogue (+/-10V) speed command. How are you going to
generate this from the parallel printer port?

Regards,
John Stanness
Norwin Electronics Ltd

"speed command" does this help ?
Brian

Offline fdos

*
  •  326 326
    • View Profile
Re: servo drive connection
« Reply #15 on: April 10, 2007, 08:06:56 AM »
Brian

Speed Command = Velocity Command which is what I called it above, but never mind!

No you can't get a velocity command direct from a printer port, but there are at least two devices that will convert stepper drive type Step and Direction commands into +-10v which effectively converts the drive to a drive working in Position Mode rather than Velocity or Torque mode.

The devices are the Skyco Pxie 100 board as mentioned above, or the Rutex R991H.   The pixue is the newest and the best priced on the market.

You original drives seem to ve Velocity type as they have a Tacho input.  As I said above I'm not certain how well any of the above devices willl work in Velocity mode rather than Torque.

The only certain thing is you are more likely to be able to get your motors working from a Gecko G320 with less headaches.

I wish you were down south I'd give yo a hand!

Wayne....

Re: servo drive connection
« Reply #16 on: April 10, 2007, 01:22:38 PM »
Thanks Wayne,
my son measured 95 volts dc going into the drive so we will have to work out a way to reduce to 80 volts
I emailed Gecko with the info from the motors and I had a look at the Skyko which seems like a good idea also
I will have a look at Rutex also.its gonna have to be make my mind up shortly.
thanks
Brian

Offline fdos

*
  •  326 326
    • View Profile
Re: servo drive connection
« Reply #17 on: April 12, 2007, 08:13:01 AM »
Brian

Well trying to convert the 95v to something the Gecko's will be happy with will probably be more work than using the Skyco Pixie boards.

I did take a look at their faq yesterday to see if there was anything about torque v's velocity modes, and it seems it should not be too much cause for concern.

The pixies are also cheaper allround to implement.

Give em a go.

Wayne....
Re: servo drive connection
« Reply #18 on: April 12, 2007, 11:19:58 AM »
Thanks Wayne,
In the process of ordering 2 boards. If they work I will order another 8 boards
Brian

Offline fdos

*
  •  326 326
    • View Profile
Re: servo drive connection
« Reply #19 on: April 25, 2007, 05:33:22 AM »
Brian

How well is your project progressing?

Wayne...
« Last Edit: April 25, 2007, 09:43:57 AM by fdos »