Author Topic: Machine Max Limits  (Read 3277 times)

0 Members and 1 Guest are viewing this topic.

Offline OCB

  • Active Member
  • Posts: 11
    • View Profile
    • My Shop
Machine Max Limits
« on: December 15, 2014, 11:25:30 AM »
Am I over looking something? I can not find how to save the Machine Max Limits??
Does this have to be set every time you open the software??
Thanks
Just an old country boy!

Offline Ron Ginger

  • Active Member
  • Posts: 921
    • View Profile
Re: Machine Max Limits
« Reply #1 on: December 15, 2014, 12:51:15 PM »
They be saved automatically, and should be there whenever you open the program. If they are not getting saved it may be because your %APPDATA% folder has somehow been set to Read Only, sometimes done by backup software or when copying from a CD.

That is usually C:\Users\{username}\Appdata\Roaming\NfsMill The tooltable, fonts, and .ini files are all there, as well as Materials.txt

Offline OCB

  • Active Member
  • Posts: 11
    • View Profile
    • My Shop
Re: Machine Max Limits
« Reply #2 on: December 15, 2014, 10:23:17 PM »
Thanks Ron I tried that and still it will not save the Machine Max Limits. I have gone as far as editing the ini file still comes up as default settings??
Just an old country boy!

Offline AutomatiqBrian

  • Active Member
  • Posts: 5
    • View Profile
Re: Machine Max Limits
« Reply #3 on: December 16, 2014, 08:16:44 AM »
I am having the same problem with setting the Machine Max Limits. I also edited the .ini file, presuming that:
Code: [Select]
[Machine]
MaxRPM=0.0000
MaxFeed=0.0000
MaxPlunge=0.0000
is the correct section for the Machine Max Limits.

Every time I start the Newfangled Mill Wizard, the Machine Max Settings default to:
Code: [Select]
Max Spindle RPM = 4500.0
Max Feed Rate = 100.00
Max Plunge Rate = 60.00

The values of 4500, 4500.0, 100, 100.0, 100.00, 60, 60.0, and 60.00 do not appear anywhere in the .ini file, so I am not sure where these values are being pulled from.

Offline OCB

  • Active Member
  • Posts: 11
    • View Profile
    • My Shop
Re: Machine Max Limits
« Reply #4 on: December 16, 2014, 08:55:44 AM »
That's the same problem I have.
Just an old country boy!

Offline OCB

  • Active Member
  • Posts: 11
    • View Profile
    • My Shop
Re: Machine Max Limits
« Reply #5 on: December 16, 2014, 09:01:09 AM »
Looks like someone else had the same problem in November but no one replied to that post??
I sure hope I don't have to enter that data every time I load the software???
Just an old country boy!

Offline AutomatiqBrian

  • Active Member
  • Posts: 5
    • View Profile
Re: Machine Max Limits
« Reply #6 on: December 16, 2014, 09:04:46 AM »
Ron's initial reply to this topic indicates that the values are supposed to be saved. This appears to simply be a bug.

Offline Ron Ginger

  • Active Member
  • Posts: 921
    • View Profile
Re: Machine Max Limits
« Reply #7 on: December 16, 2014, 09:27:52 AM »
The values 4500, 100 and 60 are hard coded defaults in the code. They are used only when the ini file does not contain settings for "MachineSettings"

I just found where the code uses [Machine] in one place and [MachineSettings] in another to store these values. Looks like a bug I will have to fix. If you edit both headings into your ini file it ought to work until I get this fixed in the next release. I will make MachineSettings the correct value.

Sorry abut that!

I have edited the source code so this fix will be in the next version. We are trying hard to get the next version out- there are a couple great new features.
« Last Edit: December 16, 2014, 09:30:23 AM by Ron Ginger »

Offline AutomatiqBrian

  • Active Member
  • Posts: 5
    • View Profile
Re: Machine Max Limits
« Reply #8 on: December 16, 2014, 09:35:21 AM »
It looks like there is also a problem with "MaxPlunge". I've added [MachineSettings] with MaxRPM, MaxFeed, and MaxPlunge. and the RPM and Feed Rate load up as the Machine Max Limits, but Max Plunge Rate stays at the default 60.00.

Offline Ron Ginger

  • Active Member
  • Posts: 921
    • View Profile
Re: Machine Max Limits
« Reply #9 on: December 16, 2014, 12:13:33 PM »
yep, it is spelled MaxPlung where it is saved and MaxPlunge where it is read.

Thanks, that is fixed now as well