Hello Guest it is December 15, 2019, 07:58:05 AM

Author Topic: Mach3 not stopping off the home switch  (Read 2209 times)

0 Members and 1 Guest are viewing this topic.

Mach3 not stopping off the home switch
« on: December 09, 2014, 11:14:24 AM »
I've been lurking and referencing for some time during my cnc build. I have one problem that I cannot seem to find the answer to, but I'm still working with it. I have the demo version of Mach3 now. I plan to purchase in 4-6 weeks when I make some money with

I have one switch per axis to act as a home AND limit switch run into a C10 BOB off a Ethernet Smooth Stepper. Each axis has two flags, one on either limit. I come off 5V on the BOB through a 220ohm resistor (current limiting resistor for 24mA for safety) to feed all limit switches with 5V. The limit switches are all NC, back to three separate inputs 11, 12 and 13 on the BOB. The inputs are pulled low through the 4.7k resistor build into the BOB. Pretty standard stuff. I check the voltages with a meter, I get 5.08V and 0.08V switched. Mach3 sees the inputs switch and this is verified on the Diagnostic screen's LED indicators. Everything appears to be set properly, the limits are all wired for the correct axis, etc, etc.

The trouble is, I send reference all home, or home individually on the diagnostic screen, the axis moves the correct direction toward the home (limit) switch, meets the switch, backs off and never stops. I have to cancel the move. If I jog into the switch I get an e-stop condition as I should. I can see the inputs going high and low just like they should, I'm just not real sure what's going on.

Let me know if you have any ideas please.

I'm at work right now, but until I get home my ideas are:
Maybe my soft limits are causing some kind of a calculation error? They should be default right now, but I'm not sure.
Set the Mach3 debounce to something higher. I'll have to look for this setting. Again, I can see the input change ok in Mach3.
Re: Mach3 not stopping off the home switch
« Reply #1 on: December 09, 2014, 06:00:23 PM »
An update:

Debounce didn't work. I've tried many values between 0 and 10,000
Soft limits didn't do anything either.

The voltages look exactly what they should. I did notice that sometimes I send it home, it hits the switch and reports a limit instead. Also I noticed that if I flick the switch with my finger, it reverses direction until I flick the switch again.

Phooey. Any takers?

Thank you,
Re: Mach3 not stopping off the home switch
« Reply #2 on: December 09, 2014, 06:33:34 PM »
Nevermind I figured it out. ESS noise filter = 100us. Works like a champ

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Mach3 not stopping off the home switch
« Reply #3 on: December 09, 2014, 07:00:27 PM »
Debounce only works with the parallel port. As you've seen, motion controllers usually will have their own noise reduction settings.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html