Hello Guest it is October 22, 2019, 08:25:24 AM

Author Topic: Needing help with screens  (Read 11811 times)

0 Members and 1 Guest are viewing this topic.

Offline BR549

*
  •  6,902 6,902
    • View Profile
Needing help with screens
« Reply #10 on: December 03, 2014, 10:48:19 AM »
Craig, sorry I mixed you up with someone else.

JUST pickin on ya , (;-) TP

Offline BR549

*
  •  6,902 6,902
    • View Profile
Needing help with screens
« Reply #11 on: December 03, 2014, 11:32:49 AM »
IF you want a bird's eye view of all the associated Code in a screenset do as Craig suggested and goto the screen XML and view . It has ALL of the screen code layed out for you to see. AND it is in screen order.

Next will be to get brave and get you a pair of sissors and a bottle of glue and get to cutting and pasting. That IS next on the list as I cannot figure out a way in the screen editor to move MAJOR things around.

(;-) TP

Offline dude1

*
  •  1,253 1,253
    • View Profile
Needing help with screens
« Reply #12 on: December 03, 2014, 01:07:33 PM »
that be madman secretary

I am going to try and do the 2 codes I wont today

Offline dude1

*
  •  1,253 1,253
    • View Profile
Needing help with screens
« Reply #13 on: December 03, 2014, 05:39:06 PM »
does anyone now the code to zero an axis after its moved to a position cant find any code for doing it

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Needing help with screens
« Reply #14 on: December 03, 2014, 06:10:40 PM »
I think this may be what your looking for Daniell.

mc.mcAxisSetPos(inst, 0, 0.000)
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline BR549

*
  •  6,902 6,902
    • View Profile
Needing help with screens
« Reply #15 on: December 03, 2014, 06:24:31 PM »
VP  ??? I cannot even get a screen button to work right  ;D

Now for those Mcodes and param calls . THAT is the cats meow IT seems that there are 2 var sets associated withe G65#vars. Var_A and #1. The Var_A populates the #1 so  the macro Parm call  use it only querries the Var_A side and does NOT effect the #1.  At least it seems that way here. I can't test with G65 here so it is just a guess as it does not show up in the Var monitor.

Does anyone know how many ways you can blow up a ScreenXML (;-) and still counting. Interresting those XML thingys

(;-) TP

Offline BR549

*
  •  6,902 6,902
    • View Profile
Needing help with screens
« Reply #16 on: December 03, 2014, 07:14:23 PM »
Well I can move a control group AND it shows the new location in the TREE, BUT it will NOT display in the editor OR in Mach4. Restart Mach4 as well still no show.

(;-) TP

Offline dude1

*
  •  1,253 1,253
    • View Profile
Needing help with screens
« Reply #17 on: December 03, 2014, 08:03:09 PM »
deep breaths

Offline dude1

*
  •  1,253 1,253
    • View Profile
Needing help with screens
« Reply #18 on: December 03, 2014, 08:17:45 PM »
thanks gents I must be missing something cant get the axis`s to zero out.

this is what I have so far.
This works
Code: [Select]
--Laser Zero
--Get the instance of the controller
local inst= mc.mcGetInstance();

mc.mcCntlGcodeExecute(inst, "G1 X10 Y10 F500");--run some g-code

--Get the out5 handle
local out5= mc.mcSignalGetHandle(inst, mc.OSIG_OUTPUT5);
--Output TOGGLE
 local outstate = mc.mcSignalGetState(out5);
 if (outstate == 1) then
   mc.mcSignalSetState(out5, false);
 else
   mc.mcSignalSetState(out5, true);

 end 

Offline BR549

*
  •  6,902 6,902
    • View Profile
Needing help with screens
« Reply #19 on: December 03, 2014, 08:49:57 PM »
Daniel I do not see any code to zero the axis . Am I missing something