Hello Guest it is May 22, 2024, 07:52:33 PM

Author Topic: Z axis not repeatable  (Read 4397 times)

0 Members and 1 Guest are viewing this topic.

Z axis not repeatable
« on: December 01, 2014, 06:29:25 PM »
I have a machine that is having a problem with the Z axis.  I am running a tool path that is generated from Aspire and it turns out to have about 85000 lines of code with almost all of them having a Z component.  When completed and returning to 0,0,0 the Z axis is off by about .070".  I have slowed the speed down to around 25 inches/minute (half of what it was) and still have the same problem.  The motors on all three axis are identical and the problem is not evident on the X and Y.  I am wondering if it is some sort of round off error on the Z axis since the Z axis has so many moves and it is a stepper system.  The post processor for Aspire produces 4 decimal places which is the same as what Mach3 has.  I ran the axis calibration and Mach3 returns a number that is not an integer. 
Does the number need to be an integer?
With so many Z moves of such small increments I am thinking that it is round off error.

Any thoughts would be appreciated.


Offline Tweakie.CNC

  • *
  •  9,204 9,204
  • Super Kitty
    • View Profile
Re: Z axis not repeatable
« Reply #1 on: December 02, 2014, 02:24:11 AM »
Hi Tim,

It is not a rounding error.

Assuming your cutter is secure and not moving in the collet...

Because +Z (upward) moves are usually G00 changing the Feed-rate will have little or no effect on the problem (as you have discovered) the issue usually relates to lost steps. Try reducing your Velocity and Acceleration settings for the Z axis (in motor tuning) by 50% and save the changes. If this cures the problem you could then experiment with the Z axis motor tuning until you achieve the best balance (the Mach3 manual's section on motor tuning refers).

Re: Z axis not repeatable
« Reply #2 on: December 02, 2014, 05:01:03 PM »

Thanks for the response.  I have been running the program with the spindle not turning so the problem of the tool moving is eliminated.  I did run a test this morning at half speed on the Z axis and checked it at lunch.  The axis was .135" off.  I cut the speed down to half of that again and started the program again and will check it this evening when I return from work.

Thanks again!


Offline RICH

  • *
  •  7,427 7,427
    • View Profile
Re: Z axis not repeatable
« Reply #3 on: December 03, 2014, 09:12:31 AM »
Something that you can try is to insert some basic code into the file such that at some points in the program you can check to see where the Z is.
By doing that you will find if the loss of position is random / repeatable, if progressive, etc.

The Z axis must be repeatable and steps per unit accurate,no backlash, etc. as those kind of things can add up in a large
program. They really show their ugly head when you do 3D work.

One culprit I delt with was inadquate Z axis torque such that the acceleration was not adequate for the small incremental moves in the quick time required when doing 3 D work. You can try lowering the max velocity and accel of the X & Y along with feed rates but keep the Z at higher values, values that will not cause skipping. Skipping can occur and one would not know it......the axis can go off on it's owne or steps can be lost and total loss of position dosn't occur.
My fix was was a new stepper motor and rework of the Z axis.

Just some thoughts,
Re: Z axis not repeatable
« Reply #4 on: December 05, 2014, 12:18:57 AM »
Thanks for the feedback.  I discovered what the problem was by accident.  I have a new machine that I just finished building and was testing the axis movement and getting ready to do the calibration of number of steps. It took around 10000 steps to move one inch and the machine that was having the problem had 2032.*********xx steps per unit.  I looked at the gecko drives on the machine that was having trouble and it was set to half step mode.  I changed it to 10 microscope and ran some tests. Problem  solved.  The older machine was using the older gecko drives that have jumpers to set the step mode.  The newer machine has newer gecko drives that default to 10 microstep.  Needless  to say that axis runs much smoother now.
Thanks for the help!