Hello Guest it is December 09, 2019, 02:48:45 AM

Author Topic: setup problem with inputs not communicating from a C-10 breakout board  (Read 4613 times)

0 Members and 1 Guest are viewing this topic.

The good news is all the outputs are fine and all axis drive motors. Trial cuts were successful. The problem is getting the input signals set up for limits. e-stop , and home. I assigned the pins and set the port in config. I get no response on the diagnostic screen when jumping/unjumping the pin and 5vdc . I toggled active hi/lo with no response.

The board is set up for both inputs and outputs.  There are 5 unused. 10, 11,12,13,15 none respond on the diagnostics screen.

I tried setting up my backup breakout board - same thing - so it must be the setup ?
Any ideas I can try would be appreciated.
Guy
Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #1 on: December 01, 2014, 09:23:54 PM »
The C10 board has (4)jumpers. The input end of the board has a jumper for the input signals, for either pull-up, or pull-down. The input signals must have the correct jumper setting, and the corresponding Active Hi/Active Lo setting in Ports and Pins to be seen by Mach3.

Limits can be wired to send a +5v to the pin, or make a pin grounded. This will be set in the Active HI, or Active Low check box, depending on the way it is wired. Also, the C10 jumper has to be set for the correct action. You can play with the settings on one switch to get it working. All of the input pins, 10, 11, 12, 13, 15 have to follow the same rule.

John
Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #2 on: December 02, 2014, 11:19:35 AM »
Thanks very much for responding. The Mach manual prefers active lo. I assumed that to send active lo I would use the +5 and the pin for the circuit. I also assumed I would want use the pull down jumper. I understand how to toggle the active hi/lo on the mach config screen.

Are my assumptions - +5 and pin  and set jumper to pull down correct?

Many thanks for your time on this.
Guy
Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #3 on: December 02, 2014, 12:00:41 PM »
Hi Guy:

Yes, that is correct. Also, if more inputs are needed, a second C10 board can be added with a PCI Parallel port card in one of the
slots. This will become port 2.

John

Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #4 on: December 02, 2014, 04:49:57 PM »
thanks - I'll run through it tonight.

Guy
Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #5 on: December 04, 2014, 06:48:23 PM »
Sorry for the delay. I had partial success.The jumper on the C-10 is set to Pull Down (1&2)
The input signals are set in Mach at
X (all three)   Port1 Pin 12 Active Lo
Y         "         "           13      "       "
Z   home only "           15      "       "
A  (all three)   "          11      "        "      (slaved to x)
E-Stop            "          10      "        "
+5v is jumped to each pin
 I'm jumping at the board to eliminate any error in connection through the switches themselves. The diagnostic screen is clear with all pins connected to 5v.
When I disconnect 5v from pin 10 I get an Estop led as expected.
When  I disconnect pin 15 from 5v I get a yellow home on m3 which is as expected.
I get no response in disconnecting power from 12, 13, 11. I have verified the 5vdc signal on all pins.
I can imagine a physical connection issue on the cable or socket or possibly a bad chip.
I'd appreciate any ideas you have.
Thanks,
Guy
Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #6 on: December 06, 2014, 06:03:02 PM »
Hi Guy:

This wiring works on my setup, with a C10 board so it should work for you.

When you open the diagnostics page, no led's from your inputs should be lit. This is a
basic Mach3 rule.TheLED's light up when the switch goes "Active."


Wire the X, Y, or Z + limit up as folows.

On the end of the C10 board with the INPUT pins is a jumper for 1-2, Pull Down,
and 2-3 Pull Up. Put the jumper in the 2-3 position.

On the micro switch NO (Normally OPen) terminal,  for the X + Limit switch, connect a Red
wire from the NO terminal to the C10 board input pin 15.


On the micro switch COM terminal for the X + Limit, connect a Black wire to the C10 board
GND terminal, or one of the COM terminals if the COM jumper is on the 1-2 position.

This jumper setting will make the COM terminals Ground.
 Do not put the jumper in the 2-3 position, as that will make the COM terminals +5v

Go to Ports and Pins, Inputs, to the X++ line, and put a Green check under the Enable
column, for that action.

Under Port, put the number of the Port. It will be a 1, unless you are using a second
Port, with (2) C10 boards.

Put 15 in the Pin # column.

Put a Green check under the Active Low column.

Click on the Apply box, and the the OK box.

Open your Diagnostic page, and you will see the X++ box in the upper right is not lit.
Manually trip your X++ Limit switch, the the X++ box will turn Green.

Wire all of your Limit switches in the exact same way.

When all of your Limit switches are working correctly, go to the Config Menu, and scroll
to the last row, and click SAVE.


Regards,

John

« Last Edit: December 06, 2014, 06:18:23 PM by mrprecise44 »
Re: setup problem with inputs not communicating from a C-10 breakout board
« Reply #7 on: December 08, 2014, 01:44:36 PM »
OK - that would be active lo instead of high.
I'll try it tonight.
Thanks
Guy