Hello Guest it is May 24, 2019, 12:00:13 PM

Author Topic: Intermittent jogging with keyboard  (Read 1435 times)

0 Members and 1 Guest are viewing this topic.

Intermittent jogging with keyboard
« on: November 23, 2014, 11:22:49 AM »
Hello,  I have a new problem that just popped up. No changes to the machine or software. Mach 3,  CNC mill.  My arrow jog keys work sometimes and sometimes not.  They work fine one minute then out of nowhere one axis or another won't jog.  It shows it jogging on screen but no table movement.  I have tried both wired usb and radio keyboards with the same results.  If a jog key is not working I can run a quick program and all axis work fine.  Just intermittent arrow key jogging.  I notice that the led lights don't change on the board that usually change when jogging.  I've tried it through smooth stepper USB and direct parallel port with same results. Checked plugs and wiring with no luck.  Any thoughts would be helpful.  Thank you.

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: Intermittent jogging with keyboard
« Reply #1 on: November 24, 2014, 04:41:51 PM »
If Mach is showing the DROs moving then it would suggest that the problem is not with the keyboard, more likely  external hardware I would think.
Hood
Re: Intermittent jogging with keyboard
« Reply #2 on: November 24, 2014, 07:45:20 PM »
Yes it seems so.  I finally can get it to repeat by jogging a certain way and it will kill the Z and Y axis.   I can watch the led lights on the sound logic board and when I get 3 lights to go out, one on each axis then Z and Y stop jogging, As soon as I push the X axis and turn the led on then everything starts working.  I think the sound logic board is biting the dust any thoughts?
Re: Intermittent jogging with keyboard
« Reply #3 on: November 24, 2014, 10:38:55 PM »
OK, after a whole day and finally seeing the light indicators being weird I took a new C10 cnc4PC  breakout board that I had on the shelf left over from horizontal cmc plasma cutters I used to build and hooked it up.   That seems to have done the trick.  I don't physically see anything wrong with the old one so I imagine an IC freaked out.