Author Topic: CSMIO/IP-S vs DELTA ASDA-B2  (Read 17470 times)

0 Members and 1 Guest are viewing this topic.

Offline TPS

  • Active Member
  • Posts: 1,116
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #30 on: December 15, 2014, 08:46:32 AM »
Hi Arman,

looks great, little bit of paint, little bit of cleaning up the wiring, finished.

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Arman

  • Active Member
  • Posts: 20
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #31 on: December 15, 2014, 09:05:35 AM »
Sure Thomas, I will paint it and wire better as soon as I finish my work and transport it to client...

Offline Arman

  • Active Member
  • Posts: 20
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #32 on: March 15, 2015, 12:55:23 PM »
Hello Thomas and Hood. I have finished my 5 axis. Whant you to see the result.

http://uploads.ru/0n1D9.jpg
http://uploads.ru/zJ5TY.jpg
http://uploads.ru/EvPNU.jpg
http://uploads.ru/0LNxj.jpg
http://uploads.ru/nF7XA.jpg
http://uploads.ru/35cSW.jpg

Also videos

https://www.youtube.com/watch?v=cAWvHIpbHBI
https://www.youtube.com/watch?v=XSjOGxWDLRg

All is good, but not 5 axis continuous. I have the impression, that the tip of the cutter moves not smooth, like waves. I am in confusion. Is it Mach problem (I even tryed with mach4 - same result)? Or may be postprocessor? Also may be it is impossible at all to do 5 axis continuous milling without RTCP? I will be very grateful for any advice...

Offline TPS

  • Active Member
  • Posts: 1,116
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #33 on: March 16, 2015, 03:36:55 AM »
Hello Arman,

your machine is impressive and looks great.

Sorry i do not have any experencie in 5 axis continous milling.

Yust a few ideas. You are talking from waves.

Have you ever tryed to mill a cycle and measured it.
in an 5 axis machine i would also try to mill a ball and measure it.

i have learned in 2.5d if you get a perfrect cycle, your axis movements are ok.

Thomas


anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Hood

  • Mach4 Alpha
  • Posts: 25,774
  • Carnoustie, Scotland
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #34 on: March 16, 2015, 05:27:19 PM »
Very nice indeed, very impressed with this router.
Regarding the 5th axis, afraid I too have never run it so can not say one way or another :(

Hood

Offline TPS

  • Active Member
  • Posts: 1,116
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #35 on: March 19, 2015, 06:53:14 AM »
Hello Arman,

today i was little bit thinking about your "wave" problem.
i think it is not mach or the cam programm.
i was thinking about your kinematics, and about tolerances there.
i made a small drawing ony in X-Z plane.
at the right side of the drawing the z-axis is twisted 0.171 degrees, and
you can see in the TCP it is more than one mm off.
i am affraid depending on your 5 axis kenematics and of the dimentions off your
machine minimal tolerances will give you big fault in milling result.

Thomas just thinking
« Last Edit: March 19, 2015, 06:57:25 AM by TPS »
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Arman

  • Active Member
  • Posts: 20
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #36 on: March 19, 2015, 08:58:10 AM »
Partly I agree with you Thomas, but on the other hand, if the machine kinematics is not true, trajectory must still go smoothly, without waves. But I am not sure... Anyway In a day I will try to double check all axis tolerances. Thanks for trying to help me...

Offline Ghantos

  • Active Member
  • Posts: 51
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #37 on: October 05, 2016, 02:40:47 AM »
Dear Sirs,

sometimes and randomaly, i get "Internal Error" WaitForMove error when i run the M6 macro From CS-lab for ATC tool changer??

often, this problem come when the Z axe move down to pick the tool.

an ePID error appere for no need, the z Axes move smoothly no problem.

most times i get the error number in line belongs to the Sleep() function and the WaitForMOve().

anybody face this problem before??

regards
Ghantos


Offline IN-WondeR

  • Active Member
  • Posts: 20
    • View Profile
Re: CSMIO/IP-S vs DELTA ASDA-B2
« Reply #38 on: December 11, 2017, 11:14:25 AM »
Arman

Did you ever get this up and running perfectly??

I see you are running Asda B2 from Delta.. Are you also running 750W servos??

I recently bought a Chinese machine that came with deltas, but it did not run properly, so I changed back to steppers until I could figure out what the problem was. It seemed the motors overshot, and did not correct them selves and so on, when moving. Tuning these drives was not se easy as one would have thought.

Do you have any experience tuning these drives??

I'm running a CSMIO/IP/M so pretty much the same setup, other that you have  more axis than I do.

Any thoughts??