Hello Guest it is June 27, 2019, 01:32:41 AM

Author Topic: Setting "steps per" on rotary (A) axis  (Read 6604 times)

0 Members and 1 Guest are viewing this topic.

Setting "steps per" on rotary (A) axis
« on: October 06, 2014, 07:16:27 PM »
Hello, new member here.

I built a motion system (Gecko 540 and Mach 3) for a laser welder and just added a rotary table to it. The rotary moves, but I can't get the "steps per" setting to have an effect on the amount of rotation.

According to my calculations the steps per degree should be 88.8888. If I set it at that and command a 120 degree move, the rotary moves about 260 degrees. If I change the steps to degree to 44, it still moves about 260 degrees. And it's the same whether it is set at 160 or 320.

Does anyone know what I'm doing wrong?

Mike K.
Re: Setting "steps per" on rotary (A) axis
« Reply #1 on: October 07, 2014, 01:29:33 AM »
Hi Mike:
There a couple of settings you need to enable.

The steps per degree should be a simple calculation based upon the ratio of the rotary table, the reduction ratio from motor to rotary table input shaft (if any), and the steps per revolution of the motor, which is usually 200 ppr for stepping motors. Also, if you are using micro-steps, this must be accounted for.

You did not say what the rotary table ratio was, and if there is any motor reduction between motor and rotary input pinion gear.

For the rotary table to act like a normal axis, go to the "config" menu, and scroll down to the heading "Toolpath."
The upper right box is labeled "Rotations." Check the axis of rotation, usually the X axis; check the A-Rotations Enabled, and check the "Use Radius for Feedrate."
Click OK, and scroll down to the bottom of the config menu, and click on "Save Settings."

Now open the "Settings" menu. Check the appropriate boxes for Axis you will be using. The X,Y, Z, and A should be black, and the B,C lit green.
The heading in the upper right corner is for "Rotation Radius." Since you checked the "Use Radius for Feedrate" in the Toolpath menu, here is where the part Radius is entered to make the axis's move in sync. Enter some general value, like 2.00 if you are using "Inches". If you are doing a real job, you should enter the actual part radius.

As before, go to the config menu and "Save your new settings.

Under "Config", open the "General Config..." page. On the left side of page is a box "Angular Properties."  Check "A Axis is Angular."  Click OK, and go to bottom of menu and "Save Settings."

Now close Mach3, and restart. Your new settings should all be enabled, and the rotary axis will act like another axis.

You must make sure the correct motor steps for 1 degree of movement. Usually, you can set the A axis Velocity and acceleration quite a lot higher than the X,Y, or Z axis.

Do a test with the MDI line. Set X to a move of something like 5", and A to about 40 degrees; G1 X5 A40 F25, and see how the two axis move. It should work in sync just like an X and Y motion.

If a command to move 40 degrees does not come out "Exact", you have made an error in the steps per degree calculation.

Also, this is all assuming you have the motor settings correct for steps per, velocity, and acceleration. This is all trial and error, and listening to the motor sound.

Hope this helps.


John
Re: Setting "steps per" on rotary (A) axis
« Reply #2 on: October 08, 2014, 11:23:48 PM »
Thank you so much! That did it for the most part.

I hadn't set Config, Toolpath, Rotations. So now, when I command a move of 120 degrees it moves 119.970 or so. I think this must be because the proper steps per degree is 88.888888............, which Mach 3 rounds to 88.88889 or such. Am I right? For my application it's not a problem at all, but I'm curious about it.

Thanks again for the response. They should put that in the book.

Mike
Re: Setting "steps per" on rotary (A) axis
« Reply #3 on: October 09, 2014, 01:25:42 PM »
Hi Mike:

Glad it's working OK now. True enough, a book with all the little "gotchas" would be handy.

Regarding the 119.970 DRO reading is really of no consequence. Mach3 does the math, and shows the numbers in the DRO to the fourth decimal place.
What is shown is .03 degree. In reality, the difference between your readout, and 120.000 degrees is not measurable with standard machinist equipment. On a 1" diameter shaft, the rotational distance on the surface is equal to .000262". You can be off more than that just trying to get the centerline of a machine spindle aligned with the rotary table rotational axis

Mach3 cannot move the rotary table any closer to 120.000, as that is the result of the basic motor resolution, the gear ratio in effect, and whatever micro-steps the amps is set to move.
However, visually, it is an annoyance not to see a nice 120.000, since that is what you programmed. If we could modify the DRO, to 2 or 3 places rounded off, that would be more pleasing. I have seen some comments on the forum about doing this.

I have a 4th. axis driven by analog servo, with encoder feedback, and still get the annoying number effect.

Now you get to play with the rollover issues, going the wrong way, why can't I .......

John

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Setting "steps per" on rotary (A) axis
« Reply #4 on: October 09, 2014, 02:45:19 PM »
Quote
If we could modify the DRO, to 2 or 3 places rounded off, that would be more pleasing. I have seen some comments on the forum about doing this.

You can alter the DRO by opening the screenset in one of the screen designers, double click the DRO and you can  then alter the format string of the DRO to show how many places after the decimal that you want. As an example a standard DRO would have this as the format string, %+.4f  If you changed that to %+.2f your DRO would have 2 positions after the decimal.
Hood
Re: Setting "steps per" on rotary (A) axis
« Reply #5 on: October 10, 2014, 01:18:48 AM »
Good suggestion, Hood.
What is the "North Britain" about. I heard the referendum did not get the votes, but that is all I know.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Setting "steps per" on rotary (A) axis
« Reply #6 on: October 10, 2014, 03:18:57 AM »
I have replied in a PM as I don't think I should really discuss politics in a forum post.
Hood